C6 Corvette General Discussion General C6 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

My clock wont work either

 
Old 03-19-2019, 10:29 PM
  #1  
JJ2007
Junior Member
Thread Starter
 
Member Since: Mar 2019
Posts: 4
Likes: 0
Liked 1 Time in 1 Post
Default My clock wont work either

Battery went dead. Everything came back with recharge EXCEPT THE CLOCK. Time buttons wont work and time block blank.
JJ2007 is offline  
Old 03-19-2019, 10:49 PM
  #2  
Vette_DD
CF Senior Member
Support Corvetteforum!
 
Vette_DD's Avatar
 
Member Since: May 2004
Posts: 71,912
Liked 570 Times in 446 Posts
Default

A little more detail about the car wouldn't hurt. Model year and whether or not it has the navigation unit. Info. might or might not help.
Vette_DD is offline  
Old 03-20-2019, 09:16 AM
  #3  
cmonkey713
CF Senior Member
 
cmonkey713's Avatar
 
Member Since: Aug 2008
Location: Edmond Oklahoma
Posts: 11,456
Liked 396 Times in 354 Posts
Default

Seems to be a common problem since sometime in December 2018. Some seem to think it has something to do with a satellite reboot cycle and may come back after April 6, 2019. Based on some Forum posts it happens to the C-6 from 2005 to 2010 or 2011. Pretty strange, I changed my battery and experienced the same thing. I guess we will just have to wait and see if our clocks come back.
cmonkey713 is online now  
Old 04-01-2019, 09:58 AM
  #4  
CSixDude
CF Senior Member
 
Member Since: Mar 2010
Location: TX
Posts: 1,419
Liked 106 Times in 70 Posts
Default

April 6th is just a few days away now. It will be interesting to see if these clock issues resolve themselves later this week. Please keep us posted if you have a car that is impacted by this and let us know if it starts working again.

https://www.gps.gov/cgsic/meetings/2017/powers.pdf
CSixDude is offline  
The following users liked this post: CSixDude
jhawk127 (04-01-2019)
Old 04-01-2019, 11:10 AM
  #5  
jrose7004
CF Senior Member
 
jrose7004's Avatar
 
Member Since: Mar 2004
Location: Oklahoma City OK
Posts: 56,250
Liked 810 Times in 716 Posts
Default

You're a member of a big club!
jrose7004 is offline  
Old 04-01-2019, 01:35 PM
  #6  
Eritosthenes
CF Senior Member
 
Eritosthenes's Avatar
 
Member Since: Aug 2006
Location: Fairview Heights IL
Posts: 2,323
Liked 98 Times in 73 Posts
Default

The battery died in my 2007 about a month ago. After replacing it, all I've had to do is re-register the windows. I had no problems with the clock before or after changing the battery. My car doesn't appear to be affected even though it was assembled in the first week of August 2006, right in the middle of the range of time that folks are reporting problems.
Eritosthenes is offline  
Old 04-01-2019, 01:51 PM
  #7  
blackvetterzo6
CF Senior Member
 
blackvetterzo6's Avatar
 
Member Since: Apr 2006
Location: DES PLAINES IL
Posts: 3,911
Liked 64 Times in 52 Posts
Default

2010-ZR1, clock gone, waiting till the 6th, other then that the system all works perfect.
blackvetterzo6 is offline  
Old 04-01-2019, 11:05 PM
  #8  
cmonkey713
CF Senior Member
 
cmonkey713's Avatar
 
Member Since: Aug 2008
Location: Edmond Oklahoma
Posts: 11,456
Liked 396 Times in 354 Posts
Default

Five more days and we will see what happens.
cmonkey713 is online now  
Old 04-02-2019, 11:25 AM
  #9  
dr_gallup
CF Senior Member
 
dr_gallup's Avatar
 
Member Since: Feb 2016
Location: SC
Posts: 1,534
Liked 145 Times in 128 Posts
Default

Originally Posted by Eritosthenes View Post
The battery died in my 2007 about a month ago. After replacing it, all I've had to do is re-register the windows. I had no problems with the clock before or after changing the battery. My car doesn't appear to be affected even though it was assembled in the first week of August 2006, right in the middle of the range of time that folks are reporting problems.
Do you have NAV? Only affects vehicles that get their clock from the GPS satellites.
dr_gallup is offline  
Old 04-07-2019, 10:00 AM
  #10  
CSixDude
CF Senior Member
 
Member Since: Mar 2010
Location: TX
Posts: 1,419
Liked 106 Times in 70 Posts
Default

If your clock still isn't working after today, please post year model of your car here.
CSixDude is offline  
Old 04-07-2019, 11:26 AM
  #11  
FortMorganAl
CF Senior Member
 
FortMorganAl's Avatar
 
Member Since: Feb 2007
Location: Currently somewhere in IL,IN,KY,TN,MO,AR,MS,AL, or FL
Posts: 8,476
Liked 191 Times in 165 Posts
Default

FortMorganAl is offline  
Old 04-07-2019, 11:35 AM
  #12  
Makdaddy
CF Senior Member
 
Member Since: Jan 2018
Posts: 109
Liked 3 Times in 3 Posts
Default still no clock

Originally Posted by CSixDude View Post
If your clock still isn't working after today, please post year model of your car here.
2007 base 3lt. No clock and GPS with slash thru square box
Makdaddy is offline  
Old 04-07-2019, 01:22 PM
  #13  
Eritosthenes
CF Senior Member
 
Eritosthenes's Avatar
 
Member Since: Aug 2006
Location: Fairview Heights IL
Posts: 2,323
Liked 98 Times in 73 Posts
Default

Originally Posted by CSixDude View Post
If your clock still isn't working after today, please post year model of your car here.
Simply changing out the battery in February didn't deprive Red of power long enough. Friday the battery was disconnected all day while the supercharger went through its 100,000 maintenance. When I drove out of the shop on April 5, I noticed I no longer had a clock. It did not re-appear on April 6. Curiously, the NAV worked perfectly and guided me home from NYC to StL no problem.

2007 C6 Conv 3LT. It came off the assembly line at BG the first week of August 2006.

Last edited by Eritosthenes; 04-07-2019 at 01:23 PM.
Eritosthenes is offline  
Old 04-07-2019, 01:42 PM
  #14  
cmonkey713
CF Senior Member
 
cmonkey713's Avatar
 
Member Since: Aug 2008
Location: Edmond Oklahoma
Posts: 11,456
Liked 396 Times in 354 Posts
Default

CLOCK IS BACK !!! Saturday April 5th at about 10:45 AM it suddenly reappeared on my 2007. I guess the April date rumor was true..
cmonkey713 is online now  
The following 2 users liked this post by cmonkey713:
Makdaddy (04-07-2019), Rhett Loveday (04-07-2019)
Old 04-07-2019, 04:30 PM
  #15  
Makdaddy
CF Senior Member
 
Member Since: Jan 2018
Posts: 109
Liked 3 Times in 3 Posts
Default

Originally Posted by cmonkey713 View Post
CLOCK IS BACK !!! Saturday April 5th at about 10:45 AM it suddenly reappeared on my 2007. I guess the April date rumor was true..
Hmmm
How long did you drive before it came back?
Makdaddy is offline  
Old 04-07-2019, 04:37 PM
  #16  
Rhett Loveday
CF Senior Member
Support Corvetteforum!
 
Rhett Loveday's Avatar
 
Member Since: Feb 2012
Location: Corpus Christi Texas
Posts: 655
Liked 13 Times in 12 Posts
Default

I will fire mine up see what happens.

Originally Posted by cmonkey713 View Post
CLOCK IS BACK !!! Saturday April 5th at about 10:45 AM it suddenly reappeared on my 2007. I guess the April date rumor was true..
Rhett Loveday is offline  
Old 04-07-2019, 06:20 PM
  #17  
cmonkey713
CF Senior Member
 
cmonkey713's Avatar
 
Member Since: Aug 2008
Location: Edmond Oklahoma
Posts: 11,456
Liked 396 Times in 354 Posts
Default

I was driving to a car show about 85 miles north for about 45 miles and looked down and there it was. Still don't have the "INFO" button illuminated on the screen. Both the clock and Info button went off at the same time but only the clock came back on. Does anyone know what is up with the Info button? I did have to re-set the clock time but noticed that the date info also popped up showing December 31, 2000. What's with that? I have not tried to reset the date function yet.

Last edited by cmonkey713; 04-07-2019 at 06:21 PM.
cmonkey713 is online now  
Old 04-07-2019, 11:28 PM
  #18  
compyelc4
Junior Member
 
compyelc4's Avatar
 
Member Since: Mar 2007
Posts: 35
Likes: 0
Liked 2 Times in 2 Posts
Default

Originally Posted by JJ2007 View Post
Battery went dead. Everything came back with recharge EXCEPT THE CLOCK. Time buttons wont work and time block blank.
Check out a brand new post on Corvette Action Center. I just experienced the same problem. Did a bunch of research and I think I found a cause (USAF) but no cure.
compyelc4 is offline  
Old 04-07-2019, 11:30 PM
  #19  
compyelc4
Junior Member
 
compyelc4's Avatar
 
Member Since: Mar 2007
Posts: 35
Likes: 0
Liked 2 Times in 2 Posts
Default

Originally Posted by CSixDude View Post
April 6th is just a few days away now. It will be interesting to see if these clock issues resolve themselves later this week. Please keep us posted if you have a car that is impacted by this and let us know if it starts working again.

https://www.gps.gov/cgsic/meetings/2017/powers.pdf
Well, we're going on April 8th and NADA!
compyelc4 is offline  
Old 04-08-2019, 03:51 PM
  #20  
LiaD
Junior Member
 
Member Since: Apr 2019
Location: Western NY
Posts: 3
Liked 0 Times in 0 Posts
Default

Us Cadillac owners with Nav are having the same issue, I jumped on your forum hoping you guys would have the answer.
LiaD is offline  

Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: