Z06 What year did the NPP exhaust come on - Page 2 - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C6 Corvette ZR1 & Z06 General info about GMs Corvette Supercar, LS9 Corvette Technical Info, Performance Upgrades, Suspension Setup for Street or Track Advertisement
Sponsored by:
Sponsored by:

[Z06] What year did the NPP exhaust come on

Reply

 
 
 
Old 07-01-2010, 10:30 PM
  #21  
ISeeRed
CF Senior Member
 
ISeeRed's Avatar
 
Member Since: Sep 2006
Location: Chesterfield MI
Posts: 256
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by dmuellenberg View Post
As long as we are being technical here , the car starts up with the baffles open all the time, as it requires the vacuum to close them, although it only takes a split second for them to close.
Yeah, but quite a few of these M2W kits default to open EVERY time you shut off the key and you have to close them EVERY time if you want it quiet....I like to choose and for it to be where I left it!
ISeeRed is offline  
Reply With Quote
Old 07-03-2010, 11:37 AM
  #22  
dmuellenberg
CF Senior Member
 
dmuellenberg's Avatar
 
Member Since: Mar 2006
Location: Maplewood MN
Posts: 1,607
Thanked 31 Times in 29 Posts
Default

Originally Posted by ISeeRed View Post
Yeah, but quite a few of these M2W kits default to open EVERY time you shut off the key and you have to close them EVERY time if you want it quiet....I like to choose and for it to be where I left it!
That's odd because mine will leave it where it is set at, don't need to reset it when I shut off the car. I know you did say 'quite a few' of them do it, so there must be different versions.
dmuellenberg is offline  
Reply With Quote
Old 07-03-2010, 11:47 AM
  #23  
AFVETTE
CF Senior Member
 
AFVETTE's Avatar
 
Member Since: Sep 1999
Location: Swansea IL
Posts: 20,074
Thanked 28 Times in 22 Posts
Default

Originally Posted by ISeeRed View Post
Yeah, but quite a few of these M2W kits default to open EVERY time you shut off the key and you have to close them EVERY time if you want it quiet....I like to choose and for it to be where I left it!
Mine stay the way I shut the car off, odd. For me that's closed so when I leave for work in the am I don't bother my neighbors.

Tom
AFVETTE is offline  
Reply With Quote
Old 07-04-2010, 01:18 AM
  #24  
ISeeRed
CF Senior Member
 
ISeeRed's Avatar
 
Member Since: Sep 2006
Location: Chesterfield MI
Posts: 256
Thanks: 0
Thanked 1 Time in 1 Post
Default

Originally Posted by dmuellenberg View Post
That's odd because mine will leave it where it is set at, don't need to reset it when I shut off the car. I know you did say 'quite a few' of them do it, so there must be different versions.
That's great! Mine always defaulted to open every time the car shut off. (Which was really annoying, I really want it quiet most of the time and only a bit louder on occasion) My switch stays wherever I leave it, and it only cost about $3!
ISeeRed is offline  
Reply With Quote
Old 04-07-2016, 07:26 PM
  #25  
gloss3
Junior Member
 
Member Since: Mar 2001
Posts: 27
Thanked 0 Times in 0 Posts
Default no go on my 2009 Mild To Wild

Have a 2009 coupe. Mild to Wild did not do anything for mine. No change in the sound. Now what?
gloss3 is offline  
Reply With Quote
Old 04-08-2016, 02:43 AM
  #26  
dmuellenberg
CF Senior Member
 
dmuellenberg's Avatar
 
Member Since: Mar 2006
Location: Maplewood MN
Posts: 1,607
Thanked 31 Times in 29 Posts
Default

Originally Posted by gloss3 View Post
Have a 2009 coupe. Mild to Wild did not do anything for mine. No change in the sound. Now what?
Could be the M2W switch is defective, a problem with the vacuum lines or the solenoid that controls the exhaust flaps. Are the flaps always open or shut? If they are shut, then you are getting vacuum so it would then be either the M2W switch or the solenoid. If the flaps are always open it is more than likely a vacuum issue.
dmuellenberg is offline  
Reply With Quote
Old 04-08-2016, 04:03 PM
  #27  
96GS#007
Tech Contributor
 
96GS#007's Avatar
 
Member Since: Apr 2000
Location: Los Angeles CA
Posts: 8,207
Thanked 186 Times in 158 Posts
Default

Originally Posted by gloss3 View Post
Have a 2009 coupe. Mild to Wild did not do anything for mine. No change in the sound. Now what?
You troubleshoot, that's what. Can we spoon feed you too?

Base Coupe or Z06?

If Base...
- May not have NPP, that was optional on the base cars. Do your mufflers have the actuators on them?

If base with optional NPP or Z06 with standard bi-modal mufflers
- M2W remote is dead
- M2W box has failed
- M2W installed incorrectly, has it ever worked?
- Failed or loose M2W connection
- Vacuum line disconnected or leaking. Could be anywhere from the front of the car aft to the mufflers.
- Solenoid failed

Btw....it's usually better to search for answers and then start a new thread with what you've tried vs digging up a Zombie thread that's nearly 6 years old.

Last edited by 96GS#007; 04-08-2016 at 04:04 PM.
96GS#007 is offline  
Reply With Quote

Thread Tools
Search this Thread
Quick Reply: [Z06] What year did the NPP exhaust come on


Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: