Does your Maggie 'Hearbeat' SC make a whining sound when you accelerate ? - CorvetteForum - Chevrolet Corvette Forum Discussion

Go Back  CorvetteForum - Chevrolet Corvette Forum Discussion > C6 Corvette, 2005 - 2013 > C6 Forced Induction/Nitrous
Reload this Page >

Does your Maggie 'Hearbeat' SC make a whining sound when you accelerate ?

Notices
C6 Forced Induction/Nitrous C6 Corvette Turbochargers, Superchargers, Pulley Upgrades, Intercoolers, Wet and Dry Nitrous Injection, Meth
Sponsored by:
Sponsored by:

Does your Maggie 'Hearbeat' SC make a whining sound when you accelerate ?

Old 01-11-2019, 04:28 PM
  #1  
Turbo6TA
CF Senior Member
Thread Starter
 
Turbo6TA's Avatar
 
Member Since: Mar 2011
Location: Florida
Posts: 7,083
Thanked 486 Times in 383 Posts
Default Does your Maggie 'Hearbeat' SC make a whining sound when you accelerate ?

I ask this question because I have never heard another Heartbeat SC besides the one on my LS3.

When I am cruising at either city or fast highway speeds, the SC makes no sound at all ... but when accelerating at anything but very light acceleration, the SC has a very pronounced whining sound to it.

Of course it's much louder of a whining at heavy acceleration, but you can still hear it whine at much lighter acceleration.

I understand that the LS9 uses the same Eaton rotor group as the Heartbeat, but I am thinking that the LS9 SC is much quieter than what I am hearing.

Can you hear yours even at very moderate city type / normal acceleration? .... I hope mine does not have a problem

Thanks,
Ron
Turbo6TA is online now  
Old 01-11-2019, 05:22 PM
  #2  
old motorhead
CF Senior Member
 
Member Since: Dec 2005
Location: Southeast TX
Posts: 4,145
Thanked 120 Times in 109 Posts
Default

It's normal. Most guys don't hear it because their exhaust covers it up. I think you can safely worry about something else. Just enjoy it!
old motorhead is offline  
The Following User Says Thank You to old motorhead For This Useful Post:
Turbo6TA (01-11-2019)
Old 01-11-2019, 05:38 PM
  #3  
Turbo6TA
CF Senior Member
Thread Starter
 
Turbo6TA's Avatar
 
Member Since: Mar 2011
Location: Florida
Posts: 7,083
Thanked 486 Times in 383 Posts
Default

Thank you sir !
Turbo6TA is online now  
Old 01-11-2019, 09:26 PM
  #4  
ysb02
CF Senior Member
 
Member Since: Aug 2008
Location: Austin TX
Posts: 1,390
Thanked 28 Times in 27 Posts
Default

Itís fine. My ctsv makes the same noise after I installed a cai. Its just normal blower noise.
ysb02 is offline  


Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: