Loss of accelerator pedal - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C6 Scan & Tune Onboard Diagnostics, Service Advice, Dyno Tuning, and Fuel Management for the Corvette
Sponsored by:
Sponsored by:

Loss of accelerator pedal

Old 09-24-2018, 09:31 PM
  #1  
DionM
Junior Member
Thread Starter
 
Member Since: Aug 2010
Posts: 35
Thanks: 0
Thanked 0 Times in 0 Posts
Default Loss of accelerator pedal

I have a 2008 automatic c6. Itís a bolt on car with a tune and small shot of nitrous. Iím running drag radials at the track and getting 1.48 60fts pretty consistent. The other night it decided to blow the tires off out of the blue ( May have been something on the track ) who knows, when I tried to pedal it, it was like there was nothing there. Kind of like the motor cut off. Then it came back alive again. This cost me a trophy lol. If I could have feathered the gas I still would have won. Anyone have any idea what would cause this? I have hp tuners but kind of a rookie.
Thanks in advance.
DionM is offline  
Old 09-27-2018, 07:57 PM
  #2  
rajahhindi
CF Senior Member
 
rajahhindi's Avatar
 
Member Since: May 2014
Location: cairns
Posts: 270
Thanked 23 Times in 20 Posts
Default

My car does that when "Active Handling" kicks in.
rajahhindi is offline  


Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: