Notices
C6 Tech/Performance LS2, LS3, LS7, LS9 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace
Sponsored by:
Sponsored by:

2010 Grand Sport Won't Pass CA Smog

 
Old 07-10-2019, 12:21 PM
  #1  
jgentle
Junior Member
Thread Starter
 
Member Since: Jul 2006
Location: Carmichael CA
Posts: 36
Received 0 Likes on 0 Posts
Default 2010 Grand Sport Won't Pass CA Smog

Agreed to buy a 2010 Grand Sport last week. Seller has been unable to get it to pass CA smog check. Car only has 9790 miles. I know it has to be driven to reset the OBD files in the PCM. I downloaded the recommended driving profile to do the reset and gave it to the owner. He drove 5 full cycles, still didn't pass. Should I go ahead and clear everything with a scan tool and start over? There is no check engine light, no codes on the scanner, and no warnings in the DIC. Even the onstar start up reports to the owners iPhone shows everything in the green. Don't want this one to get away. Help!
jgentle is offline  
Old 07-10-2019, 12:53 PM
  #2  
SilverC54me
CF Senior Member
 
SilverC54me's Avatar
 
Member Since: Jul 2004
Location: Brea CA
Posts: 1,839
Received 117 Likes on 111 Posts
Default

Have him go to another smog shop. sounds like this one possibly has bad equipment.

Gary
SilverC54me is online now  
Old 07-10-2019, 01:30 PM
  #3  
919cw313
CF Senior Member
 
919cw313's Avatar
 
Member Since: Jan 2016
Location: PNW
Posts: 3,790
Received 403 Likes on 334 Posts
2018 C6 of Year Finalist
Default

If it's unsellable in CA and it's a fire sale, let me know. But I wish you the best in getting it fixed.

Last edited by 919cw313; 07-10-2019 at 01:33 PM.
919cw313 is offline  
Old 07-10-2019, 06:37 PM
  #4  
dieselracer
CF Senior Member
 
Member Since: Mar 2017
Location: SAN DIEGO CALIFORNIA
Posts: 160
Likes: 0
Received 8 Likes on 8 Posts
Default

All the monitors must not be set. You have to hook up to the OBD2 and look at the emissions readiness monitors. I use my torque app to check mine before taking it in.
dieselracer is offline  
Old 07-10-2019, 06:42 PM
  #5  
davidfarmer
CF Senior Member
Support Corvetteforum!
 
davidfarmer's Avatar
 
Member Since: Sep 1999
Location: CONCORD NC
Posts: 10,702
Received 111 Likes on 93 Posts
Default

Is the car stock......ie should it be able to pass?
davidfarmer is offline  
Old 07-10-2019, 08:46 PM
  #6  
Sphurley
CF Member
 
Sphurley's Avatar
 
Member Since: Mar 2017
Location: Lake Mathews Ca
Posts: 51
Likes: 0
Received 13 Likes on 11 Posts
Default

I had the same problem at my two year mark for a smog check in CA. I tried the same smog station multiple times and then drove to a different on and it passed with flying colors. First guy said the same thing your getting.
"the system monitors are not ready" Mind you I had put 500miles since the first test till the third test and then moved on. And I do have a Tech II and it did not show emissions monitors not ready.
Go find a new test station
Sphurley is offline  
Old 07-11-2019, 09:18 AM
  #7  
jgentle
Junior Member
Thread Starter
 
Member Since: Jul 2006
Location: Carmichael CA
Posts: 36
Received 0 Likes on 0 Posts
Default

That seems like a viable option. Thanks for the input from all.
jgentle is offline  
Old 07-11-2019, 09:57 AM
  #8  
[email protected]
Supporting Vendor
 
subfloor@centurytrans's Avatar
 
Member Since: Feb 2011
Posts: 2,315
Received 229 Likes on 174 Posts
C6 of Year Winner (track prepared) 2019
Default

Originally Posted by jgentle View Post
Agreed to buy a 2010 Grand Sport last week. Seller has been unable to get it to pass CA smog check. Car only has 9790 miles. I know it has to be driven to reset the OBD files in the PCM. I downloaded the recommended driving profile to do the reset and gave it to the owner. He drove 5 full cycles, still didn't pass. Should I go ahead and clear everything with a scan tool and start over? There is no check engine light, no codes on the scanner, and no warnings in the DIC. Even the onstar start up reports to the owners iPhone shows everything in the green. Don't want this one to get away. Help!
The tune can be modified to pass without having to do the stupid drive cycle thing.

PM me as I'm not that far from you.
subfloor@centurytrans is offline  
Old 07-11-2019, 03:44 PM
  #9  
farmington
CF Senior Member
 
farmington's Avatar
 
Member Since: Aug 2017
Location: metro detroit Michigan
Posts: 1,619
Received 224 Likes on 174 Posts
Default

Maybe move from Cali?
farmington is online now  
Old 07-12-2019, 11:40 AM
  #10  
86SC
CF Senior Member
 
Member Since: Oct 2005
Location: CT
Posts: 186
Received 21 Likes on 18 Posts
Default

Originally Posted by [email protected] View Post
The tune can be modified to pass without having to do the stupid drive cycle thing.

PM me as I'm not that far from you.
have you modified a tune and pass?

i'm not in california but if you turn off the emissions in the tune the monitor's will never come ready.
86SC is offline  
Old 07-12-2019, 01:01 PM
  #11  
[email protected]
Supporting Vendor
 
subfloor@centurytrans's Avatar
 
Member Since: Feb 2011
Posts: 2,315
Received 229 Likes on 174 Posts
C6 of Year Winner (track prepared) 2019
Default

Originally Posted by 86SC View Post
have you modified a tune and pass?

i'm not in california but if you turn off the emissions in the tune the monitor's will never come ready.
I've shown several people how to do it on their own and the readiness tests always show as complete immediately.
subfloor@centurytrans is offline  
Old 07-13-2019, 04:38 PM
  #12  
3X2
CF Senior Member
 
3X2's Avatar
 
Member Since: Jan 2000
Location: home
Posts: 2,095
Received 165 Likes on 135 Posts
Default

no mileage exemption in california? we have a under 5000 mile per year in Pa.
3X2 is offline  
Old 07-13-2019, 07:20 PM
  #13  
Sphurley
CF Member
 
Sphurley's Avatar
 
Member Since: Mar 2017
Location: Lake Mathews Ca
Posts: 51
Likes: 0
Received 13 Likes on 11 Posts
Default

There are parts of CA, cities in certain counties that you can get an exception if there are no CARB smog stations in the area. That is the only exception I know of.
Sphurley is offline  
Old 07-13-2019, 08:31 PM
  #14  
farmington
CF Senior Member
 
farmington's Avatar
 
Member Since: Aug 2017
Location: metro detroit Michigan
Posts: 1,619
Received 224 Likes on 174 Posts
Default

So glad no smog check in Michigan.
No front plate either. But we do have to deal with 5 month winters so I guess it all evens out.
farmington is online now  
Old 07-15-2019, 09:29 AM
  #15  
86SC
CF Senior Member
 
Member Since: Oct 2005
Location: CT
Posts: 186
Received 21 Likes on 18 Posts
Default

Originally Posted by [email protected] View Post
I've shown several people how to do it on their own and the readiness tests always show as complete immediately.
i've disabled my post o2 test when i installed long tube headers. the o2s monitor always flashes not ready.
86SC is offline  
Old 07-15-2019, 01:34 PM
  #16  
[email protected]
Supporting Vendor
 
subfloor@centurytrans's Avatar
 
Member Since: Feb 2011
Posts: 2,315
Received 229 Likes on 174 Posts
C6 of Year Winner (track prepared) 2019
Default

Originally Posted by 86SC View Post
i've disabled my post o2 test when i installed long tube headers. the o2s monitor always flashes not ready.
It needs to be done in the Engine Diagnostics section of the tune.
subfloor@centurytrans is offline  
Old 07-15-2019, 05:23 PM
  #17  
[email protected]
Supporting Vendor
 
subfloor@centurytrans's Avatar
 
Member Since: Feb 2011
Posts: 2,315
Received 229 Likes on 174 Posts
C6 of Year Winner (track prepared) 2019
Default

Originally Posted by 86SC View Post
i've disabled my post o2 test when i installed long tube headers. the o2s monitor always flashes not ready.
Sorry, I should have been a little clearer before.

In the Engine Diagnostics window there's a DTC tab. For anything that sounds even remotely related to an O2 sensor you need to have the SES Enabled box checked and under Error Mode it needs to be "3 - No Error Reported'. If you do this for all the other tests as well (EVAP, EGR etc) you should be able to have all systems show as ready. The one exception is the EVAP which most people complain about not being able to get it to work but I got lucky on this. Since EVAP is related to the fuel system, I took a brute-force approach and did the same thing to anything that sounded fuel system related and ended up getting it to work. So far I've never been able to not help somebody getting everything clear.

Hope that helps.
subfloor@centurytrans is offline  
Old Yesterday, 02:54 PM
  #18  
86SC
CF Senior Member
 
Member Since: Oct 2005
Location: CT
Posts: 186
Received 21 Likes on 18 Posts
Default

Originally Posted by [email protected] View Post
Sorry, I should have been a little clearer before.

In the Engine Diagnostics window there's a DTC tab. For anything that sounds even remotely related to an O2 sensor you need to have the SES Enabled box checked and under Error Mode it needs to be "3 - No Error Reported'. If you do this for all the other tests as well (EVAP, EGR etc) you should be able to have all systems show as ready. The one exception is the EVAP which most people complain about not being able to get it to work but I got lucky on this. Since EVAP is related to the fuel system, I took a brute-force approach and did the same thing to anything that sounded fuel system related and ended up getting it to work. So far I've never been able to not help somebody getting everything clear.

Hope that helps.
thanks, i'll have to try this.
86SC is offline  

Thread Tools
Search this Thread
Quick Reply: 2010 Grand Sport Won't Pass CA Smog


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: