Notices
C7 General Discussion General C7 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

Roof Panel Issue. (Solved)

 
Old 07-19-2015, 01:44 AM
  #1  
MASTRO
Junior Member
Thread Starter
 
Member Since: May 2015
Posts: 26
Thanked 3 Times in 2 Posts
Default Roof Panel Issue. (Solved)

2015 Z51 A8. Car is 2 months old. Roof went on easy first 45 days then last week was a little tough to get back on. I didn't think much of it, figured I just had it angled wrong or something.
Tonight couldn't get it on for anything so I "forced" it on. The drivers side front would not go in the hole. I had to lock in passenger side, snap middle latch and put decent pressure on driver side while turning handle.
I came to the forum and read every thing on roof issues, seems there were plenty of rattle issues but no didn't fit issues.
Went back downstairs at midnight and really inspected it and found the issue.

Picture 1 shows the drivers side hole near windshield. It shows some white in there which is actually part of the tab from the top. (Guess I used a little pressure when forcing it in. )
Picture 2 shoes the front tab with a little of the tab rubbed off.
Picture 3 is tab that is on back of roof. This is where issue was. It was completely loose. So loose it didn't go into rear hole enough to set proper alignment. Tightened it up and top slid in like butter.
MASTRO is offline  
Old 07-19-2015, 01:47 AM
  #2  
MASTRO
Junior Member
Thread Starter
 
Member Since: May 2015
Posts: 26
Thanked 3 Times in 2 Posts
Default Pic 1

Pic 1
Attached Images  
MASTRO is offline  
Old 07-19-2015, 01:48 AM
  #3  
MASTRO
Junior Member
Thread Starter
 
Member Since: May 2015
Posts: 26
Thanked 3 Times in 2 Posts
Default Pic 2

Pic 2
Attached Images  
MASTRO is offline  
Old 07-19-2015, 01:49 AM
  #4  
MASTRO
Junior Member
Thread Starter
 
Member Since: May 2015
Posts: 26
Thanked 3 Times in 2 Posts
Default Pic 3

Pic 3
Attached Images  
MASTRO is offline  
Old 07-19-2015, 12:51 PM
  #5  
Vetteman Jack
Moderator
Support Corvetteforum!
 
Vetteman Jack's Avatar
 
Member Since: Mar 2001
Location: Missouri. Currently own 2014 Stingray Coupe.
Posts: 266,090
Thanked 3,795 Times in 3,326 Posts
MO Events Coordinator
St. Jude Co-Organizer
St. Jude Donor '03-'04-'05-'06-'07-'08-'09-'10-'11-'12-'13-'14-'15-'16-'17-'18-'19
NCM Sinkhole Donor
CI 5, 8 & 11 Veteran

Default

Good you got it solved and it didn't take a trip to the dealer.
Vetteman Jack is offline  
Old 07-20-2015, 12:20 AM
  #6  
CaryKen
CF Senior Member
 
CaryKen's Avatar
 
Member Since: Jan 2005
Location: Cary NC
Posts: 1,055
Thanked 21 Times in 13 Posts
Default

I had a similar symptom with a completely different cause. Just in case somebody ever comes to this thread through a search because they are having the problem.

In my case, I discovered that the rubber weatherstripping at the rear corner (above the window and where the back of the roof panel meets the body) had gotten pinched upwards. The panel was pressing against a bubble of rubber poking up where it should be lying down. Once you see it, it's easy to flatten the rubber strip back into place so the roof slips back into its docking position. But if you are sitting inside the cabin wondering why you can't get the latches to engage, you can't see the rubber and have no idea that is causing the problem until you get out and examine it.

Just one more thing to check if you find you are having to force the lid into position.

CaryKen is offline  
Old 07-20-2015, 06:37 AM
  #7  
vetehead
CF Senior Member
 
vetehead's Avatar
 
Member Since: Jul 2007
Location: Massapequa NY
Posts: 1,453
Thanked 2 Times in 2 Posts
Default

The permanent resolution is on its way. The squeak and rattle engineers has been looking at this for a while now. It seems as the the creaking / rattling sound a lot of coupe owners are experiencing is from the 2 front strikers/receivers mounted to windshield header. If I got it right they are already in production on MY 16 and should be available via SOP and a tsb will be issued. I sure hope this is the fix as this is the one and only noise I'm still chasing in my car!

Last edited by vetehead; 07-20-2015 at 07:29 AM.
vetehead is offline  
Old 07-20-2015, 07:41 AM
  #8  
Snake.Oiler
CF Senior Member
Support Corvetteforum!
 
Snake.Oiler's Avatar
 
Member Since: Aug 2010
Location: F'burg VA
Posts: 3,154
Thanked 48 Times in 42 Posts
St. Jude Donor '13, '14, '15-'16-'18
Default

Are those attachments really large for everyone? For some reason attachments are showing at full resolutions, whereas other linked images show based on my forum settings.
Snake.Oiler is offline  
Old 07-20-2015, 10:32 AM
  #9  
bilzvette
Junior Member
 
bilzvette's Avatar
 
Member Since: Sep 2006
Posts: 49
Thanked 1 Time in 1 Post
Default Check on interior motion alarm

If you have 2 or 3 LT interior with the interior motion alarm, you might check that alarm and make sure it still works. I had my car in the dealer for 2-1/2 weeks trying to get it fixed. Told them when I brought it in that I had concerns with the drivers side windshield switch, but since it didn't show up on the computer, they dismissed that idea. Finally after two weeks and repeated calls to Chevy, they checked that switch and it was broken, they replaced it and the alarm worked as intended. Just saying that all that "forcing fit" might have damaged the windshield switch.
Good Luck,
bill
bilzvette is offline  

Thread Tools
Search this Thread
Quick Reply: Roof Panel Issue. (Solved)


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: