A8 Tranny - Have they fixed it? - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C7 General Discussion General C7 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

A8 Tranny - Have they fixed it?

Reply

 
 
 
Old 07-11-2018, 10:49 AM
  #1  
CorvetteRL
CF Senior Member
Support Corvetteforum!
Thread Starter
 
CorvetteRL's Avatar
 
Member Since: Nov 2004
Location: Waynesville/Sylva NC
Posts: 788
Thanked 6 Times in 3 Posts
Default A8 Tranny - Have they fixed it?

So, all the info on the A8 issues - has Chevy fixed the problems in the 2018 or 2019s?

Thx!
CorvetteRL is offline  
Reply With Quote
Old 07-11-2018, 10:55 AM
  #2  
Thunder22
CF Senior Member
 
Thunder22's Avatar
 
Member Since: May 2004
Location: NY/LI/NJ
Posts: 24,931
Thanked 830 Times in 592 Posts
Default

I didn't have any problems with my 2017 so there's that.......
Thunder22 is online now  
Reply With Quote
Old 07-11-2018, 11:00 AM
  #3  
saleen556
CF Senior Member
 
Member Since: May 2010
Posts: 1,131
Thanked 277 Times in 180 Posts
Default

I wouldn't worry about the issue if you want an auto. The issues are rare if you consider how many are sold. You just hear about issues more on the internet as people vent about them.
saleen556 is offline  
Reply With Quote
The Following 4 Users Say Thank You to saleen556 For This Useful Post:
beaversstonehaven (07-13-2018), jimmie jam (08-15-2018), robert miller (07-20-2018), woodsguy (07-20-2018)
Old 07-11-2018, 11:02 AM
  #4  
Kevin A Jones
CF Senior Member
Support Corvetteforum!
 
Kevin A Jones's Avatar
 
Member Since: Apr 2017
Location: Virginia
Posts: 2,561
Thanked 1,217 Times in 740 Posts
Default

There was communication that it was fixed during the 2017 model year production (can't remember right now what the exact build date was)
however that certainly doesn't mean that no car after will ever have an A8 issue. My 2017 GS has been problem free.
Kevin A Jones is offline  
Reply With Quote
Old 07-11-2018, 11:04 AM
  #5  
sunsalem
CF Senior Member
 
sunsalem's Avatar
 
Member Since: Sep 2014
Posts: 8,484
Thanked 1,236 Times in 934 Posts
Default

A8 is fine...buy with confidence.
sunsalem is offline  
Reply With Quote
Old 07-11-2018, 11:07 AM
  #6  
Patman
CF Senior Member
 
Patman's Avatar
 
Member Since: May 2001
Location: Oakville Ontario
Posts: 12,949
Thanked 1,020 Times in 628 Posts
Default

I have 5600 trouble free miles on my 2018 so far and I let it go into V4 mode all the time as well.
Patman is offline  
Reply With Quote
Old 07-11-2018, 11:29 AM
  #7  
2kvetmy
CF Senior Member
 
2kvetmy's Avatar
 
Member Since: Jul 2004
Location: Jefferson County Alabama
Posts: 554
Thanked 24 Times in 23 Posts
Default

I have 18000 on my Aug 2016 build date / 2017 with no problems
2kvetmy is offline  
Reply With Quote
Old 07-11-2018, 11:35 AM
  #8  
DAVE396LT1
CF Senior Member
 
DAVE396LT1's Avatar
 
Member Since: Jul 2003
Location: Redmond WA
Posts: 7,141
Thanked 1,353 Times in 900 Posts
Default

No problems here with my A8... but then I have a Z and the problems I saw were all in Stingrays, so...
DAVE396LT1 is online now  
Reply With Quote
Old 07-11-2018, 11:38 AM
  #9  
ExRedRacer
CF Senior Member
 
ExRedRacer's Avatar
 
Member Since: Aug 2004
Location: The Beautiful Pacific Northwest
Posts: 23,945
Thanked 857 Times in 473 Posts
St. Jude Donor '05-'06-'07-'08-'09, '14-'15-'16-'17-'18

Default

Just turned over 14,000 miles on my 2016 Z51 with a build date of 1/16 and have had zero problems. It runs flawlessly. I do have the Range device so it's always in V8 mode and that might have something to do with it.
ExRedRacer is offline  
Reply With Quote
Old 07-11-2018, 11:46 AM
  #10  
Mike Mercury
CF Senior Member
 
Mike Mercury's Avatar
 
Member Since: Apr 2001
Location: S.W. Ohio. . . . . . NRA Life Member
Posts: 54,058
Thanked 84 Times in 61 Posts
Default

I have 8k miles on my 2015 that was built on day two of production. No problems yet; though last month I installed that "Range" module.
FYI... the highly reported issue is actually with the torque converter... and not the A8 transmission; though I see that some vision them together as a single unit.
Mike Mercury is offline  
Reply With Quote
The Following User Says Thank You to Mike Mercury For This Useful Post:
robertbruce (07-12-2018)
Old 07-11-2018, 12:00 PM
  #11  
iclick
CF Senior Member
 
iclick's Avatar
 
Member Since: Mar 2013
Location: Baton Rouge LA
Posts: 2,420
Thanked 297 Times in 238 Posts
Default

Originally Posted by Mike Mercury View Post
FYI... the highly reported issue is actually with the torque converter... and not the A8 transmission; though I see that some vision them together as a single unit.
Well, the A8 as a complete assembly has documented more issues than just the TC, like delayed engagement and intermittent hard shifts. Like the TC problem the former requires pulling the tranny to fix (replace stator and add some o-rings), but the latter is usually fixed by a software reset and relearn. I was lucky and my 2015 had only the first two issues , but only the TC was repaired since I could never demonstrate the delayed engagement problem to a dealer service rep. This was even though the tranny was already out of the car. I threw in the towel two weeks later, as I've lamented more than once in the past.

Last edited by iclick; 07-11-2018 at 12:01 PM.
iclick is offline  
Reply With Quote
Old 07-11-2018, 01:12 PM
  #12  
Rebel Yell
CF Senior Member
 
Rebel Yell's Avatar
 
Member Since: Jan 2006
Location: Down south in Dixie
Posts: 5,088
Thanked 1,521 Times in 1,085 Posts
Default

My '16 A8 (3/16 build) has been just fine. And, the bad transmission threads have become less, and less.
Rebel Yell is offline  
Reply With Quote
Old 07-11-2018, 01:32 PM
  #13  
kaplana08
CF Senior Member
 
kaplana08's Avatar
 
Member Since: Feb 2016
Posts: 330
Thanked 66 Times in 52 Posts
Default 2019

There was a report about a bad torque Converter on a 2019 right out of the box reported on this forum a couple of weeks ago.Research it.
kaplana08 is offline  
Reply With Quote
Old 07-11-2018, 01:53 PM
  #14  
teenVette
CF Senior Member
Support Corvetteforum!
 
teenVette's Avatar
 
Member Since: Jul 2010
Location: Bonaire GA
Posts: 3,212
Thanked 14 Times in 14 Posts
Default

So far so good with my ‘16
teenVette is offline  
Reply With Quote
Old 07-11-2018, 02:02 PM
  #15  
Glenmcp
CF Senior Member
Support Corvetteforum!
 
Glenmcp's Avatar
 
Member Since: Feb 2013
Location: Central Gulf Coast Florida
Posts: 1,738
Thanked 65 Times in 51 Posts
Default

My 17 Z06 A8 runs just fine. Forums are a magnet for problem reports.
Glenmcp is offline  
Reply With Quote
Old 07-11-2018, 02:09 PM
  #16  
jonebone
CF Member
 
jonebone's Avatar
 
Member Since: Sep 2013
Location: Calvert County MD
Posts: 95
Thanked 13 Times in 11 Posts
Default

My A8 is fine. One trick people recommend is to put it in manual and shift 1 2 1 before driving off in the morning. This is easy for me since I live in a long driveway and I like to go slow when leaving to keep the car as clean as possible.

My point being, even if yours wasn't fine, there is a workaround.
jonebone is offline  
Reply With Quote
Old 07-11-2018, 02:16 PM
  #17  
dfettero
CF Senior Member
 
Member Since: Jan 2016
Posts: 385
Thanked 54 Times in 41 Posts
Default 33K miles on 2016 A8

33K miles on 2016 A8 with NO issues.

Originally Posted by CorvetteRL View Post
So, all the info on the A8 issues - has Chevy fixed the problems in the 2018 or 2019s?

Thx!
dfettero is offline  
Reply With Quote
Old 07-11-2018, 02:29 PM
  #18  
PegasusCapital
CF Senior Member
Support Corvetteforum!
 
PegasusCapital's Avatar
 
Member Since: May 2015
Location: Chicago IL
Posts: 685
Thanked 113 Times in 91 Posts
Default

The best way to "fix" the A8 problem is to defeat AFM from forcing the engine into V4 mode. Lots of posts on this topic. Spend $200 on a Range Technology unit and you'll be worry free. It's a great transmission otherwise.
PegasusCapital is offline  
Reply With Quote
The Following User Says Thank You to PegasusCapital For This Useful Post:
Mike Mercury (07-11-2018)
Old 07-11-2018, 02:36 PM
  #19  
netster
CF Senior Member
 
netster's Avatar
 
Member Since: Oct 2007
Location: Charles Town WV
Posts: 316
Thanked 21 Times in 15 Posts
Default

18,500 miles on my 2016. No problems so far.
netster is offline  
Reply With Quote
Old 07-11-2018, 03:26 PM
  #20  
japc5
CF Senior Member
 
japc5's Avatar
 
Member Since: Apr 2008
Location: Liverpool NY
Posts: 853
Thanked 38 Times in 26 Posts
Default

I just broke 5000 miles on my 2018 GS and have had no issues with the A8 or the car for that matter.
japc5 is offline  
Reply With Quote
The Following User Says Thank You to japc5 For This Useful Post:
JDMilw (07-14-2018)

Thread Tools
Search this Thread
Quick Reply: A8 Tranny - Have they fixed it?


Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: