2017 Grand Sport Clicking - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C7 Tech/Performance Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace
Sponsored by:
Sponsored by:

2017 Grand Sport Clicking

Old 12-28-2017, 03:25 PM
  #1  
Sutton720
Junior Member
Thread Starter
 
Member Since: Dec 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default 2017 Grand Sport Clicking

I have a 2017 Grand Sport that began the infamous CLICKING at around 3,000 miles. I have had it cleaned and torqued twice and they replaced the rotors. It is still clicking loudly and it is when turning left or right at any speed. Has GM had ANY luck resolving this?
Sutton720 is offline  
Old 12-28-2017, 05:55 PM
  #2  
Ray7374
CF Member
Support Corvetteforum!
 
Ray7374's Avatar
 
Member Since: Nov 2017
Posts: 56
Thanks: 0
Thanked 7 Times in 5 Posts
Default

Mine is doing the same at 2200 miles? I have not had the cleaning/tq done. Did it help?

Last edited by Steven Bell; 12-28-2017 at 11:08 PM.
Ray7374 is offline  
Old 12-28-2017, 07:57 PM
  #3  
Sutton720
Junior Member
Thread Starter
 
Member Since: Dec 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

It helped for about one week!! I am very upset with the situation! They have me sitting on my hands waiting for a fix from GM. It is embarrassing and annoying!
Sutton720 is offline  
Old 12-28-2017, 07:59 PM
  #4  
Ray7374
CF Member
Support Corvetteforum!
 
Ray7374's Avatar
 
Member Since: Nov 2017
Posts: 56
Thanks: 0
Thanked 7 Times in 5 Posts
Default

Originally Posted by Sutton720 View Post
It helped for about one week!! I am very upset with the situation! They have me sitting on my hands waiting for a fix from GM. It is embarrassing and annoying!
Wow Iím about to take mine to the dealer for the first time for this. Is there any service bulletin that you know of I can reference
Ray7374 is offline  
Old 12-28-2017, 09:25 PM
  #5  
Marcho Polo
CF Senior Member
 
Marcho Polo's Avatar
 
Member Since: Mar 1999
Location: Fort Worth Texas
Posts: 7,694
Thanked 208 Times in 140 Posts
Former Moderator
Cruise-In I Veteran
Cruise-In II Veteran
Cruise-In III Veteran
Default

Originally Posted by Ray7374 View Post
Wow Iím about to take mine to the dealer for the first time for this. Is there any service bulletin that you know of I can reference
I believe this one covers the issue with the rim mating surface needing to be cleaned:

#PI1498B: Clicking Noise from Front and/or Rear Wheels - (Aug 23, 2016)

I have had this done three times, and still have the noise on my 2015 Z51. They also re-torqued the axle nut, and I believe inspected splines or something.

The cleaning never did anything for my noise. When they re-torqued the axle nut, it seemed to help for a day or two, but the noise is back.

Service manager told me he got some new equipment in recently that has several microphones that they can attach and try to isolate where the noise is. He said I would need to leave the car with him for probably 10 days as they drive it and try to figure it out. I daily drive my car and I'm not too fond of leaving it there for them to drive around for 10 days. Not sure what I'm going to do next.
Marcho Polo is offline  
Old 12-28-2017, 09:29 PM
  #6  
Marcho Polo
CF Senior Member
 
Marcho Polo's Avatar
 
Member Since: Mar 1999
Location: Fort Worth Texas
Posts: 7,694
Thanked 208 Times in 140 Posts
Former Moderator
Cruise-In I Veteran
Cruise-In II Veteran
Cruise-In III Veteran
Default

by the way, here is a video demonstrating the noise on my car. It seems worse in the rear passenger area on my car. You can hear a very loud click at the beginning, and then hear it click on and off as I load and unload the wheel changing gears or letting off the gas:

Marcho Polo is offline  
The Following User Says Thank You to Marcho Polo For This Useful Post:
ateupjoe (06-10-2018)
Old 12-28-2017, 10:03 PM
  #7  
Sutton720
Junior Member
Thread Starter
 
Member Since: Dec 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Marcho Polo posted the correct reference! Very upset that we get our dream cars and then GM can’t even figure this out!
It is strange because it does it cold/hot/wet or dry.. and it seems to get louder to me but it might just be that I am irritated!
Changing the rotors did absolutely NOTHING ! So I have the serve Manager staying on top of it but still no luck!
Sutton720 is offline  
Old 12-28-2017, 10:15 PM
  #8  
Marcho Polo
CF Senior Member
 
Marcho Polo's Avatar
 
Member Since: Mar 1999
Location: Fort Worth Texas
Posts: 7,694
Thanked 208 Times in 140 Posts
Former Moderator
Cruise-In I Veteran
Cruise-In II Veteran
Cruise-In III Veteran
Default

is the sound in my video what everyone else is hearing?
Marcho Polo is offline  
Old 12-28-2017, 10:46 PM
  #9  
Sutton720
Junior Member
Thread Starter
 
Member Since: Dec 2017
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by Marcho Polo View Post
is the sound in my video what everyone else is hearing?
man I canít seem to get the video to play... but by sliding the dial it appears that you arenít turning the wheels! Mine does it when turning the wheel left and right and rolling forward or backward at all speeds!
Sutton720 is offline  
Old 12-28-2017, 11:04 PM
  #10  
Marcho Polo
CF Senior Member
 
Marcho Polo's Avatar
 
Member Since: Mar 1999
Location: Fort Worth Texas
Posts: 7,694
Thanked 208 Times in 140 Posts
Former Moderator
Cruise-In I Veteran
Cruise-In II Veteran
Cruise-In III Veteran
Default

Originally Posted by Sutton720
man I canít seem to get the video to play... but by sliding the dial it appears that you arenít turning the wheels! Mine does it when turning the wheel left and right and rolling forward or backward at all speeds!
It's the rear wheel in the video. I do turn in the video and the noise happens while turning or going straight.
Marcho Polo is offline  
Old 12-29-2017, 09:11 AM
  #11  
Ray7374
CF Member
Support Corvetteforum!
 
Ray7374's Avatar
 
Member Since: Nov 2017
Posts: 56
Thanks: 0
Thanked 7 Times in 5 Posts
Default

Originally Posted by Sutton720 View Post
man I canít seem to get the video to play... but by sliding the dial it appears that you arenít turning the wheels! Mine does it when turning the wheel left and right and rolling forward or backward at all speeds!
Mine is a very rhythmic ( as though it were one click per revolution) that sounds like its coming from the back.Someone brought it to my attention when I was pulling through the pits after driving on track. I noticed it when a friend was driving my car on a go kart/autocross track. I was standing on the side of the track and every time he drove around a right or left turn it sounded like a rock in the tire but louder .
Ray7374 is offline  
Old 12-30-2017, 03:28 AM
  #12  
djnice
CF Senior Member
 
djnice's Avatar
 
Member Since: Jun 2016
Location: Eastern WA
Posts: 2,457
Thanked 400 Times in 351 Posts
Default

Originally Posted by Marcho Polo View Post
by the way, here is a video demonstrating the noise on my car. It seems worse in the rear passenger area on my car. You can hear a very loud click at the beginning, and then hear it click on and off as I load and unload the wheel changing gears or letting off the gas:
Totally different than what I thought everyone was complaining about. That is way better than the GS and Z06 issues where they click constantly whenever you turn.

Last edited by djnice; 12-30-2017 at 03:29 AM.
djnice is offline  
Old 01-07-2018, 10:36 PM
  #13  
Mwk
Junior Member
 
Mwk's Avatar
 
Member Since: Nov 2016
Posts: 17
Thanks: 0
Thanked 3 Times in 3 Posts
Default

I got a 17 GS and my car experienced clicking noises as I turned the wheel and car. As it turned out it was alignment screws. These cars create incredible amount of torque on the alignment parts and they have to be tightened to something past 200 lbs. Most of them are not and as the car turns it will make noise.
Give it a try and I hope this helps.

By the way, most dealers or techs will not know that, I got lucky when I came in to my dealer as they just figured that out on another customers car.
Mwk is offline  
The Following User Says Thank You to Mwk For This Useful Post:
djnice (01-08-2018)
Old 01-12-2018, 06:49 PM
  #14  
c5racr1
CF Senior Member
 
Member Since: Feb 2000
Location: new orleans
Posts: 1,905
Thanked 69 Times in 63 Posts
Default

Had that problem, put amt camber bolts and granatelli toe rods, all gone. So i guess it’s one of the 2 causing the problem
c5racr1 is offline  
Old 04-23-2018, 08:44 PM
  #15  
onebad1lE
CF Senior Member
 
Member Since: Dec 2012
Posts: 169
Thanks: 0
Thanked 17 Times in 15 Posts
Default

My car did same thing found loose bolt on control arm
onebad1lE is offline  
Old 04-23-2018, 10:07 PM
  #16  
Ray7374
CF Member
Support Corvetteforum!
 
Ray7374's Avatar
 
Member Since: Nov 2017
Posts: 56
Thanks: 0
Thanked 7 Times in 5 Posts
Default

Originally Posted by onebad1lE View Post
My car did same thing found loose bolt on control arm
i did find a solution - just like the TSB talks about - I removed the wheels cleaned off the mounting surface and re installed , noise gone
Ray7374 is offline  
Old 04-23-2018, 10:21 PM
  #17  
sonny615
CF Member
 
sonny615's Avatar
 
Member Since: Jul 2015
Location: Webster New York
Posts: 80
Thanked 25 Times in 23 Posts
Default

Did the rotor and wheel mating surface clean. Noise went away after I tightened the rear axle nuts. Been gone since doing that last year.
sonny615 is offline  
Old 04-24-2018, 10:54 AM
  #18  
djnice
CF Senior Member
 
djnice's Avatar
 
Member Since: Jun 2016
Location: Eastern WA
Posts: 2,457
Thanked 400 Times in 351 Posts
Default

I found that cleaning only worked for 1000 miles.
djnice is offline  
Old 04-24-2018, 12:45 PM
  #19  
Dado5
CF Senior Member
 
Dado5's Avatar
 
Member Since: Jan 2010
Location: Walnut Creek CA
Posts: 739
Thanked 19 Times in 16 Posts
Default

My 18GS does this when turning left or right . Font wheels clicking , sounds like there are nails in tires and making clicking noise. Car has 1300 miles.
Dado5 is offline  
Old 04-24-2018, 02:25 PM
  #20  
village idiot
CF Senior Member
 
village idiot's Avatar
 
Member Since: Oct 2011
Posts: 5,194
Thanked 609 Times in 424 Posts
Default

Originally Posted by Dado5 View Post
My 18GS does this when turning left or right . Font wheels clicking , sounds like there are nails in tires and making clicking noise. Car has 1300 miles.
That's probably Ackermann.
village idiot is offline  

Thread Tools
Search this Thread
Quick Reply: 2017 Grand Sport Clicking


Sponsored Ads
Vendor Directory

Contact Us About Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: