Go Back  CorvetteForum - Chevrolet Corvette Forum Discussion > C7 Corvette > C7 Z06 Discussion
Reload this Page >

'14/'15 Z51, Z06 Owners - Chime in if you updated your HMI

Notices
C7 Z06 Discussion General Z06 Corvette Discussion, LT4 Corvette Technical Info, Performance Upgrades, Suspension Setup for Street or Track
Sponsored by:
Sponsored by:

'14/'15 Z51, Z06 Owners - Chime in if you updated your HMI

 
Old 02-18-2018, 03:04 PM
  #1  
Flame Red
CF Senior Member
Thread Starter
 
Flame Red's Avatar
 
Member Since: May 1999
Location: Windermere FL
Posts: 5,287
Thanked 521 Times in 336 Posts
Default '14/'15 Z51, Z06 Owners - Chime in if you updated your HMI

There have been a few threads here about updating car play/android auto in '14 & '15 models.

Consensus is that if you own a '14 or '15 1LT base Stingray, the HMI update works perfectly. We have at least one verified forum member.

The question is that for Z06, or Z51 models. Some of the vendors state if you upgrade the HMI to a '16 model year (or later) you will loose the ability to change the drive mode settings if your car is a '14 or '15 Z51 or Z06. They state that starting in the '16 model year, GM moved some of the drive setting to a different module and the '16 HMI is not compatible with this change and you loose the ability to change certain drive settings.

Other vendors seem to indicate the '16 HMI works perfectly and you lose no settings on Z51 or Z06 models.

If you have a '14 or '15 Z51 or Z06 and have upgraded your HMI, please post the link for the unit you purchased and please post your feedback if you lost any drive mode setting, ability to change exhaust settings, or change/set initial drive mode for the display.

If you want to post about how stupid it is to upgrade, and it is waste of $ and we are idiots and flame this thread - please don't bother posting! We don't care about your opinions. We just want feedback from folks that did the upgrade on '14/'15 Z51 or Z06 please!


Last edited by Flame Red; 02-18-2018 at 03:09 PM.
Flame Red is offline  
The Following 6 Users Say Thank You to Flame Red For This Useful Post:
Boiler_81 (02-19-2018), jimmbbo (03-06-2018), Minnesota122001 (07-19-2018), Pete43 (02-26-2018), Toz (02-19-2018), Z51VetteFan (05-10-2018)
Old 02-19-2018, 04:32 PM
  #2  
Flame Red
CF Senior Member
Thread Starter
 
Flame Red's Avatar
 
Member Since: May 1999
Location: Windermere FL
Posts: 5,287
Thanked 521 Times in 336 Posts
Default

Flame Red is offline  
Old 02-19-2018, 05:45 PM
  #3  
Jeff V.
CF Senior Member
 
Jeff V.'s Avatar
 
Member Since: Dec 2017
Location: Kansas City MO
Posts: 1,663
Thanked 664 Times in 406 Posts
Default

Stay tuned. I'm gathering the parts and equipment to do this myself. Once I get the last few items, I'll do a full write up.
Jeff V. is offline  
The Following 2 Users Say Thank You to Jeff V. For This Useful Post:
Flame Red (02-20-2018), Minnesota122001 (07-19-2018)
Old 02-20-2018, 01:35 AM
  #4  
itch808
CF Senior Member
 
Member Since: Jan 2018
Location: Honolulu, HI
Posts: 147
Thanked 34 Times in 18 Posts
Default

Looking forward to hearing your results
itch808 is offline  
Old 02-20-2018, 08:36 AM
  #5  
LbulletM
CF Senior Member
 
Member Since: Aug 2013
Location: Waverly Tennessee
Posts: 1,015
Thanked 66 Times in 48 Posts
Default

Originally Posted by Jeff V. View Post
Stay tuned. I'm gathering the parts and equipment to do this myself. Once I get the last few items, I'll do a full write up.
Make sure you mention it here when you post so that we don't miss it!
LbulletM is offline  
Old 02-20-2018, 10:24 AM
  #6  
Jeff V.
CF Senior Member
 
Jeff V.'s Avatar
 
Member Since: Dec 2017
Location: Kansas City MO
Posts: 1,663
Thanked 664 Times in 406 Posts
Default

I will. I'm picking up used parts and doing the programming myself. I'll document the process end to end.
Jeff V. is offline  
Old 02-22-2018, 02:17 PM
  #7  
Flame Red
CF Senior Member
Thread Starter
 
Flame Red's Avatar
 
Member Since: May 1999
Location: Windermere FL
Posts: 5,287
Thanked 521 Times in 336 Posts
Default



I have to believe that someone with a '14/15 Z06 or Z51 has already updated their HMI...

Flame Red is offline  
Old 02-23-2018, 12:26 AM
  #8  
socratesis
Junior Member
 
Member Since: Feb 2018
Location: Las Cruces New Mexico
Posts: 16
Thanked 3 Times in 2 Posts
Default

I updated the HMI and Radio in my 2014 z51 3lt. Until I read about losing settings for driving mode I hadnít realized it was gone. My install worked great, BUT, my steering wheel controls wonít activate Siri or hang up the phone on CarPlay. Everything else works as it should. I was told that the 2014 cluster is incompatible with CarPlay and have considered changing it. Iíve had CarPlay in my last 3 cars, itís important to me. I hope this helped in some way...
socratesis is offline  
The Following 2 Users Say Thank You to socratesis For This Useful Post:
Flame Red (02-23-2018), Minnesota122001 (07-19-2018)
Old 02-23-2018, 12:13 PM
  #9  
Jeff V.
CF Senior Member
 
Jeff V.'s Avatar
 
Member Since: Dec 2017
Location: Kansas City MO
Posts: 1,663
Thanked 664 Times in 406 Posts
Default

Originally Posted by Flame Red View Post


I have to believe that someone with a '14/15 Z06 or Z51 has already updated their HMI...

I just ordered the radio module to do mine. Scored a cheap IO5 HMI a few days ago. I'm going extra crazy and trying to keep my HD radio while I'm at it. I should have results in another week or so.
Jeff V. is offline  
Old 02-23-2018, 12:29 PM
  #10  
LbulletM
CF Senior Member
 
Member Since: Aug 2013
Location: Waverly Tennessee
Posts: 1,015
Thanked 66 Times in 48 Posts
Default

Originally Posted by socratesis View Post
I updated the HMI and Radio in my 2014 z51 3lt. Until I read about losing settings for driving mode I hadnít realized it was gone. My install worked great, BUT, my steering wheel controls wonít activate Siri or hang up the phone on CarPlay. Everything else works as it should. I was told that the 2014 cluster is incompatible with CarPlay and have considered changing it. Iíve had CarPlay in my last 3 cars, itís important to me. I hope this helped in some way...
Android Auto is what I'm looking for. New unit, then? I'm getting the intermittent blackouts anyways. (2014 Z51)
LbulletM is offline  
Old 02-23-2018, 01:20 PM
  #11  
socratesis
Junior Member
 
Member Since: Feb 2018
Location: Las Cruces New Mexico
Posts: 16
Thanked 3 Times in 2 Posts
Default

I think mine is compatible with both android and CarPlay. Yest I bought it new from infotainment I think... I havenít had any problems with it besides the typical CarPlay challenges associated with ever updating iphones. I havenít seen any black outs as such....
socratesis is offline  
Old 02-23-2018, 01:26 PM
  #12  
Jeff V.
CF Senior Member
 
Jeff V.'s Avatar
 
Member Since: Dec 2017
Location: Kansas City MO
Posts: 1,663
Thanked 664 Times in 406 Posts
Default

I think I read that the Cadillac guys have the same problem with the steering wheel controls when they do this upgrade. Dunno if anyone ever found a workaround for it.
Jeff V. is offline  
The Following User Says Thank You to Jeff V. For This Useful Post:
socratesis (02-23-2018)
Old 02-23-2018, 03:03 PM
  #13  
LbulletM
CF Senior Member
 
Member Since: Aug 2013
Location: Waverly Tennessee
Posts: 1,015
Thanked 66 Times in 48 Posts
Default

Originally Posted by socratesis View Post
I think mine is compatible with both android and CarPlay. Yest I bought it new from infotainment I think... I havenít had any problems with it besides the typical CarPlay challenges associated with ever updating iphones. I havenít seen any black outs as such....
Yea, they're all compatible with both. You're saying you bought a whole new radio unit, right?

The original installed '14 radios had problems with losing video connection, hence blackouts.
LbulletM is offline  
The Following User Says Thank You to LbulletM For This Useful Post:
socratesis (02-23-2018)
Old 02-23-2018, 07:08 PM
  #14  
socratesis
Junior Member
 
Member Since: Feb 2018
Location: Las Cruces New Mexico
Posts: 16
Thanked 3 Times in 2 Posts
Default

Thatís interesting about the cadillacís, I would not be surprised at all. The gentleman from infotainment said that if i updated the gauge cluster it would work. I am still considering it.
I did buy the combo, the HMI and the Radio unit that goes below the passenger side carpet. I didnít know about the video issues, good to know... The cluster is under $400, if I ever find a how to on itís replacement I will purchase it and give it a go...
socratesis is offline  
Old 03-04-2018, 01:47 AM
  #15  
Jeff V.
CF Senior Member
 
Jeff V.'s Avatar
 
Member Since: Dec 2017
Location: Kansas City MO
Posts: 1,663
Thanked 664 Times in 406 Posts
Default

Finally got this done late last night. It's mostly good news.

I bought used parts off eBay for under $200. I did the programming myself since I have an MDI.

Yes, I lost the drive mode menu. Part of my motivation for doing this was because I thought I might have a workaround for that problem. It didn't pan out. I like experimenting with this stuff. So if it didn't work, oh well. After playing with it some more, I realized I'll probably never use that menu anyway. But the faster UI and Android Auto will benefit me every time I drive the car. I might be able to get the drive mode menu back by swapping in a newer chassis control module, but I'm not going to waste my time and money unless I can find one for pocket change.

Here's the good news. You can keep your HD Radio if you get the correct hardware. Mine is working perfectly. Also, you do not need to replace the USB socket. I left mine alone and my phone talks to the car via USB just fine for Android Auto. The SD card slot still works too. I think the only reason GM changed it in 2016 was as a cost cutting measure, and/or to avoid confusion with the SD slot used for the PDR on models that have it.

Getting the HMI module out was slightly annoying, but getting to the radio module was a huge pain. My hands are all torn up. It's located in the passenger foot well, behind the PDR bracket/footrest, and behind the body control module (BCM) bracket. I was never able to remove the thing properly due thick wire bundles and cable ties that were attached to it. I'd love to find the GM engineer who thought this was a good idea and make him or her replace one of these radios, then ask if they still think it's a good design. Anyway, I was just barely able to fish the radio out around the side of the BCM bracket. Getting it clipped back into place was almost as hard.

By the way, if you do this, don't freak out if you lose your outside temperature display. After doing some reading, it looks like that happens when you disconnect the battery. It's got nothing to do with the HMI or radio upgrade. Mine came back the 2nd time I started the car after I reconnected the battery.

Despite the hassles, it was well worth it. Counting the programming subscription, I'm still well under $250 into this. I don't count the cost of the MDI since I can use that for future troubleshooting and projects.
Jeff V. is offline  
The Following 2 Users Say Thank You to Jeff V. For This Useful Post:
Flame Red (03-04-2018), The Yav (05-11-2018)
Old 03-04-2018, 04:20 PM
  #16  
Flame Red
CF Senior Member
Thread Starter
 
Flame Red's Avatar
 
Member Since: May 1999
Location: Windermere FL
Posts: 5,287
Thanked 521 Times in 336 Posts
Default

Originally Posted by Jeff V. View Post
Finally got this done late last night. It's mostly good news.

I bought used parts off eBay for under $200. I did the programming myself since I have an MDI.

Yes, I lost the drive mode menu. Part of my motivation for doing this was because I thought I might have a workaround for that problem. It didn't pan out. I like experimenting with this stuff. So if it didn't work, oh well. After playing with it some more, I realized I'll probably never use that menu anyway. But the faster UI and Android Auto will benefit me every time I drive the car. I might be able to get the drive mode menu back by swapping in a newer chassis control module, but I'm not going to waste my time and money unless I can find one for pocket change.

Here's the good news. You can keep your HD Radio if you get the correct hardware. Mine is working perfectly. Also, you do not need to replace the USB socket. I left mine alone and my phone talks to the car via USB just fine for Android Auto. The SD card slot still works too. I think the only reason GM changed it in 2016 was as a cost cutting measure, and/or to avoid confusion with the SD slot used for the PDR on models that have it.

Getting the HMI module out was slightly annoying, but getting to the radio module was a huge pain. My hands are all torn up. It's located in the passenger foot well, behind the PDR bracket/footrest, and behind the body control module (BCM) bracket. I was never able to remove the thing properly due thick wire bundles and cable ties that were attached to it. I'd love to find the GM engineer who thought this was a good idea and make him or her replace one of these radios, then ask if they still think it's a good design. Anyway, I was just barely able to fish the radio out around the side of the BCM bracket. Getting it clipped back into place was almost as hard.

By the way, if you do this, don't freak out if you lose your outside temperature display. After doing some reading, it looks like that happens when you disconnect the battery. It's got nothing to do with the HMI or radio upgrade. Mine came back the 2nd time I started the car after I reconnected the battery.

Despite the hassles, it was well worth it. Counting the programming subscription, I'm still well under $250 into this. I don't count the cost of the MDI since I can use that for future troubleshooting and projects.
Thank you for leading the way!

I think I would follow in your foot steps if I had an MDI (I don't) and I could find used parts for under $300, but I cannot. Unlikely I could find anyone locally that would program the parts for me for a small fee. Guess that is why the vendors charge big $ for the parts.

To make sure I understand exactly what one looses, is it that you loose the drive settings under the "settings" menu in the center console display or do you loose the ability to change it using the steering wheel controls on display on the dash between the speedometer and the tach?

Also, for the settings that are lost - what does the car use for those settings? Or one never knows since you can no longer see them?

Last edited by Flame Red; 03-04-2018 at 04:28 PM.
Flame Red is offline  
Old 03-04-2018, 05:40 PM
  #17  
itch808
CF Senior Member
 
Member Since: Jan 2018
Location: Honolulu, HI
Posts: 147
Thanked 34 Times in 18 Posts
Default

Would be interesting to hear what someone who splurges for the updated i06 unit rather than the i05 and see if they keep drive settings
itch808 is offline  
Old 03-04-2018, 07:21 PM
  #18  
Jeff V.
CF Senior Member
 
Jeff V.'s Avatar
 
Member Since: Dec 2017
Location: Kansas City MO
Posts: 1,663
Thanked 664 Times in 406 Posts
Default

Originally Posted by Flame Red
To make sure I understand exactly what one looses, is it that you loose the drive settings under the "settings" menu in the center console display or do you loose the ability to change it using the steering wheel controls on display on the dash between the speedometer and the tach?

Also, for the settings that are lost - what does the car use for those settings? Or one never knows since you can no longer see them?
You lose the "Drive Mode" menu on the center infotainment screen. You can no longer customize exhaust volume or steering effort independent of the pre-defined drive modes.

You can still select the various instrument cluster displays using the steering wheel controls, you can still select the drive modes using the center console ****, and you can still chose to have your cluster displays independent of the drive modes.

The only thing that I've seen that has changed with the cluster is I now get text message notifications there. That wasn't even an option for 2014 or 2015, so it's interesting that the older cluster can display the new content.

Originally Posted by itch808
Would be interesting to hear what someone who splurges for the updated i06 unit rather than the i05 and see if they keep drive settings
I'm skeptical that it would work on IO6 but not IO5. The 2016 HMI software has those menus on both IO5 and IO6. The HMI module actually has a whole lot of 'extra' software. This is probably a topic for a different thread, but I've downloaded an HMI update file and looked at its contents. It's got software and branding for all 4 GM brands. I also found software pointers to the drive mode menu. I think the problem is GM changed something elsewhere in the car, and now the HMI can't talk to the necessary modules. Since it's not receiving the correct network messages, it's not displaying the menu.
Jeff V. is offline  
Old 03-05-2018, 01:27 AM
  #19  
socratesis
Junior Member
 
Member Since: Feb 2018
Location: Las Cruces New Mexico
Posts: 16
Thanked 3 Times in 2 Posts
Default

Mine is now the I06 and I no longer have the settings for the drive mode. I actually believe they updated the gague cluster, based on what I was told regarding my steering wheel controls working for everything besides the phone controls specific to CarPlay. The distributor said that other 14ís and 15ís (I think) have had that problem and he said the cluster is incompatible.
socratesis is offline  
Old 03-05-2018, 10:42 AM
  #20  
Jeff V.
CF Senior Member
 
Jeff V.'s Avatar
 
Member Since: Dec 2017
Location: Kansas City MO
Posts: 1,663
Thanked 664 Times in 406 Posts
Default

You don't control the exhaust and steering in the cluster on a stock 2014, so why would the cluster have anything to do with losing the menu when you go to a 2016 HMI?
Jeff V. is offline  

Thread Tools
Search this Thread
Quick Reply: '14/'15 Z51, Z06 Owners - Chime in if you updated your HMI


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: