CorvetteForum - Chevrolet Corvette Forum Discussion - View Profile: Bill Curlee

Notices
Support Corvetteforum!

Bill Curlee Bill Curlee is offline

Tech Contributor

Visitor Messages

Showing Visitor Messages 1 to 10 of 140
  1. DWC4
    07-16-2018 10:17 AM
    Bill, this find saved me hours and $$ on my C5, that the dimmer for dash lights/HuD if turned all the way to right past detente, is a battery killer. Thanks for all you do here, greatly appreciated!
    Doug

    https://www.corvetteforum.com/forums...siic-draw.html
  2. DKZC5
    07-06-2018 05:06 PM
    Hello Bill. I've been think about you, hope all is well. I tried to chat with you a couple of times, but no word back. I ran a PCV system and catch can. Cleaned the intake, changed plugs, and 02 Sensors like you told me too. However, my car never made it home a month ago when I took him out for a test and a few WOT hits to blow out the sea foam and dialectic lube. Turned out to be an $8k costly mistake, but hope to have it back next week.
  3. Terry Cole
    04-19-2018 01:46 PM
    My 2000 C5 had a very intermittent starting problem. Would turn key to start and SOMETIMES would only get flashing dash lights and clicking noise. Usually could cycle off and it would start fine. I checked battery connections and they were fine. Finally it refused to start at all. Had it towed to dealer where they replaced battery. Two days later same thing. My wife had it that day. Had it towed to dealer. They kept it for a week. Again would only not start sometimes. Suggested grounds as per your post. Asked them to clean them since they had the car. When I got home checked them myself. They had cleaned the connection at the frame but had not pulled the plugs apart. I did and there was corrosion in them. Cleaned them and no problems for two weeks now. Thanks for the info.
  4. solo25
    03-23-2018 10:57 AM
    Bill, I've been getting the 0338 code on my 2003 corvette, which looks like a problem with the inside temperature sensor. I've checked the wires, but don't know how to test the sensor itself without the expensive scanner. I think it's bad, and I see that the part is almost impossible to find as its not manufactured anymore. Is there a different sensor that i could substitute for mine, or and I do away with it altogether? Or any other ideas? I wanted to clear the code, but if everything works, i can live with it. Any help would be greatly appreciated.
  5. agp45
    07-07-2017 06:30 PM
    Mr. Curlee, I have seen you corresponding with different members so I thought I would ask you what you think is my problem with my 2005 C6. I had a battery that had died car would not crank but all accessories worked fine took battery to have it load tested and was replaced under warranty bad cell. I installed new battery and car cranks runs fine a/c radio works but windows,mirrors,seats,trunk release,doors (use door release to exit) checked all fuses good both fuse boxes and no codes show up on code reader. I think it could be BCM but not sure any help is greatly appreciated! Ashley Powell from SC
  6. solo25
    05-17-2017 02:35 PM
    Bill, I've got a 2003 base version Vette, automatic. I'm doing some restoration, and decided to take the alternator to a local shop to have it checked out and cleaned up. The guy called me and said it might be cheaper to replace it than to have him work on it. He was talking about "diplexer" pulley or something and I didn't really understand. What I'm wondering is, where can I get a replacement that works for my car. I remember a few years ago a friend had the same car, and he replaced the alternator with a remanufactured on from AutoZone, and it wouldn't keep the batter charged. What exactly should I look for? any help will be appreciated.
  7. stickystyles
    04-05-2017 07:13 PM
    Mr. Curlee, I am in need of your assistance.. My vette was recently in a rain storm. I don't know if it was struck by lighting or it was because of the heavy downpour. Problems are the all of the systems have a no comms. reading... Seeking your input as to what may be the problem. I've researched all of your previous posts and have checked for wetness, and I'm tried disconnecting the battery in order to reboot the system. No success. Please help if you have the time.
  8. wheelswheeler
    08-24-2016 02:23 PM
    Bill,
    I am at wits end and have, I believe; read everything on here but may have missed something. My blower motor on 2000 Manual A/C will not come on. Checked all the fuses, Had motor checked it works when loaded to a 12 volt batt., replaced the module, still no go. What should I do next? Thanks, Wheels
  9. Cleonard
    08-04-2016 04:23 PM
    Bill,

    I need help with a PCM No Comm issue. Last week I lost lights to my driver side power windows and they wouldn't work from either door. Locks and mirrors worked fine. I then pulled out the wires from the accordions and wiggled them. Both sides have the exposed wire with clear shield. Currently these wires are pulled out of the door to insure they are not grounding out. I unplugged all four connectors (2 in each door) and checked for corrosion or bent plugs. None. I also removed the grey connectors by the BCM and infected for the same. Nothing. I have verified no blown fuses but still need to verify voltage and ground. I checked the PCM ground by the starter. The BCM shows no sign of oxidation. Current symptoms are: windows work, car starts and runs, REP, fuel shows empty, codes are:PCM No Comm, TCE U1000 H C, BCM U1255 H C, SDM U1000 H C, SDM U1016 H C, BO-RFA U1000 H C. Any advice you could offer will be greatly appreciated.

    Colby
  10. Ruzty
    07-29-2016 07:56 PM
    Bill,

    I'm getting High Oil Temp with the temp at 392. The IPC reads 392 cold also and seems to be stuck at that reading even with the sensor disconnected. I changed the oil temp sensor and check the wires. I'm lost...2000 Vert

About Me

  • About Bill Curlee
    Full Name
    Bill Curlee
    Location
    Gales Ferry CT
    Your Zip Code
    06335
    Occupation
    SSN-688 and SSN-774 Class Submarine Field Rep.
    Year & Model
    65 Coupe (under const); 71 Coupe; 98 Coupe(sold); 02 ZO6 & 06 Z51 Coupe (sold) 11 MN6 Grand Sport V
    Color
    TBD, White, Electron Blue Z, O6, Inferno Orange
    Mods
    Vararam, Stainless Works Headers, 3" Mid section, High Flow Cats, Home Ported 90mm TB, Home Ported FAST 90, Patriot Stage 2 heads, Caddy Racing Lifters, Kirban Ripper Shifter. CCW-=505a rims with Toyo Proxis 19" T1R tires
    Biography
    Retired US Navy E8 (26 yrs) Submarine Fire Control Technician. FTCS (SS) Currently fixing the ships I use to serve on! Submarine Field Rep. Live to drive Corvettes!
    Country of Residence
    US
  • Signature
    Harder, Better, Faster, Stronger

Statistics

Total Posts
Visitor Messages
Total Thanks
General Information
  • Member Since: 06-04-2001

Friends

Showing Friends 1 to 10 of 85
Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.