CorvetteForum - Chevrolet Corvette Forum Discussion - View Profile: Corvette_Ed


Corvette_Ed Corvette_Ed is offline

CF Senior Member

Visitor Messages

Showing Visitor Messages 1 to 4 of 4
  1. Vet Interested
    03-10-2018 01:46 PM
    Vet Interested
    Hey Corvette Ed,
    Gary in San Diego. Like you, I have a Kenwood head unit in my car. Mine is an older model (DNX890HD). Do you have a front camera installed? If so how do you turn it on when needed? My backup camera activates in reverse but not sure when the front camera would be on since I do not want it on all the time. Thanks
  2. CadVette
    05-09-2017 03:39 PM
    CadVette
    Corvette Ed it's CadVette. I live in Arlington. I'm a little confused as to why you would want to take the hood insulation off of your car but if you're looking to get rid of it I need it for my original hood. The hood insulation on my aftermarket hood has a hole cut in it for the C7 style vent.
  3. Corvette_Ed
    11-23-2013 04:25 PM
    Corvette_Ed
    Ben, the best person to talk to about your problem is Bill Curley. He hangs out in the Tech forum. Tell him exactly what you said here and he'll point you in the right direction. The first thing you'll need to do is to post any codes the DIC is showing. What's the voltage on the battery?
  4. FunFunFun
    11-09-2013 06:36 PM
    FunFunFun
    Corvette_Ed, Ben here. I have a 2004 model with 37,000 miles and have had extensive electrical problems. First, the battery stayed drained and the dealer replaced a computer related to the dashboard lights. Then, I replaced the battery and alternator (Bosch) and I am having a recurring problem. When I start the car, the instrument gauges and light stay on for a few seconds and then nothing works but the car runs well. Then, the gauges begin to work and a light comes on the dashboard which says "Check Gauges" and then below a light says "High Voltage" but then these lights go out and the gauges work for awhile. The dashboard lights and gauges went out tonight but window display works. When I turned the car off, the lower display read "Low Voltage". I have had the alternator and battery checked. Although somewhat low, the battery works well . Can you steer me in the right direction? Thanks, Ben

About Me

  • About Corvette_Ed
    City
    Dallas/Ft. Worth
    Occupation
    Tech Support Engineer
    Year & Model
    2008 C6 Convertible
    Color
    Victory Red
    Mods
    Kenwood 9902 head unit.

    More to come!
    Country of Residence
    US
    Gender
    Male

Statistics

Total Posts
Albums
Visitor Messages
Total Thanks
General Information
  • Member Since: 05-12-2012

Friends

Showing Friends 1 to 2 of 2
Sponsored Ads
Vendor Directory

All times are GMT -4. The time now is 05:49 PM.


We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.