CorvetteForum - Chevrolet Corvette Forum Discussion - Search Results

Notices
 
Search: Posts Made By: MN80Vette
Showing results 1 to 25 of 499
Search took 1.98 seconds.
11-02-2018, 01:18 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

D'oh!

It was late last night when I finally shut the lights off in the garage. I didn't even check this thread then because I wouldn't have done anything about it then anyway. I just read your reply a...
11-01-2018, 11:19 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

I agree. When it was working, the GM 350 HO was...

I agree. When it was working, the GM 350 HO was running better than advertised.
The oil and air leak from the valley problem is fixed and ground is fixed too. Everything I know I didn't do correctly...
11-01-2018, 10:47 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

It's time to call FAST .

The connector cap was definitely missing as the without-with pictures show.
...
10-31-2018, 08:24 AM
Replies: 38
Views: 1,061
Posted By MN80Vette

Cheap fix?

I just found the following post on the CPG Nation/FAST forum:
" After months of rough running and various weird problems, 2 new o2 sensors, new map sensor, new tps sensor. numerous phone calls to...
10-30-2018, 10:57 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

I just explained the problem in a FAST "Send Us A...

I just explained the problem in a FAST "Send Us A Message" contact and asking them they recommend to fix the fickle connector switch and what my options are.
I hope they respond soon. :toetap:
...
10-30-2018, 10:20 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

Solution to the problem changed the problem!

Connecting the ground directly to the battery terminal fixed the ~half V drop to the O2 sensor, but now there seems to be an ECU connector plug problem.

Now, when I turn on the ignition, the ECU...
10-30-2018, 08:39 AM
Replies: 38
Views: 1,061
Posted By MN80Vette

Ground problem

I measured 12V from pin 3 of the 6-pin O2 connector (orange wire) to vehicle ground (engine), but I only got 11.48V when I measured between pin 3 and pin 4 of the O2 connector (sensor heater ground,...
10-29-2018, 04:41 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

My system is similar to yours with 1 7/8" ceramic...

My system is similar to yours with 1 7/8" ceramic coated headers but with a 2 1/2" mandrel bend exhaust with X-pipe. I installed but O2 sensor just a few inches from the collector to sample exhaust...
10-29-2018, 12:30 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

The O2 sensor is a few inches behind the...

The O2 sensor is a few inches behind the collector in the passenger side pipe. Overheating might still be a problem that close to the collector. I will start by chasing #1. If the voltage is good,...
10-29-2018, 11:58 AM
Replies: 38
Views: 1,061
Posted By MN80Vette

That makes sense. I just found instructions for...

That makes sense. I just found instructions for testing that problelm:
"Does your O2 sensor heat up now? If it does not you need to troubleshoot the wiring to find out why. With the key on you...
10-29-2018, 10:03 AM
Replies: 38
Views: 1,061
Posted By MN80Vette

Yes, fixing the intake gasket leak fixed the...

Yes, fixing the intake gasket leak fixed the problem main problem as the picture of a before-fix spark plug and after-fix (and 280 miles) spark plus show:
...
10-28-2018, 05:03 PM
Replies: 14
Views: 719
Posted By MN80Vette

4.5# fubbed on my '80

I put BOSS 338 wheels with 4.5" BS on my '80 and the tires rubbed on the frame (maybe due in part to Steeroids). Put on a set of 3/8" thick hub centric adapter-spacers in the front. That fixed the...
10-20-2018, 10:19 AM
Replies: 27
Views: 3,889
Posted By MN80Vette

The $24K for improvements was for the parts ONLY,...

The $24K for improvements was for the parts ONLY, and that was for just the major parts, not including hoses, caps, wire, hardware, etc.. The only labor I paid for was to blow the primer, base coat...
10-16-2018, 07:41 AM
Replies: 27
Views: 3,889
Posted By MN80Vette

Not quite yet. A C3 Forum member had his plane...

Not quite yet. A C3 Forum member had his plane ticket to pick it up, but I discovered a few problems while I was prepping it for his drive home. I asked him to wait for me to fix them.
I will update...
10-10-2018, 12:21 AM
Replies: 3
Views: 183
Posted By MN80Vette

Do you take PayPal? If so, plz send a pm with...

Do you take PayPal? If so, plz send a pm with your PayPal email address.
Thanks!
10-09-2018, 11:30 PM
Replies: 3
Views: 183
Posted By MN80Vette

'88-'96 Headlight Actuator Control Module

Real GM part preferred. Verified that it works.
Thanks.
10-07-2018, 02:30 PM
Replies: 38
Views: 1,061
Posted By MN80Vette

My engine is a GM Performance 350 HO crate, and...

My engine is a GM Performance 350 HO crate, and GM built Gen 1 small block engines for decades. I searched online and didn't find ANY mention of leaky rocker studs on GM Performance crate engines.
...
10-07-2018, 09:58 AM
Replies: 38
Views: 1,061
Posted By MN80Vette

Oh snap. That's a lot worse than a bad sensor....

Oh snap. That's a lot worse than a bad sensor. Now I notice that the spark plug with little fouling does not have oil on the threads. Here is a picture of 4 spark plugs. The oil on the threads is...
10-07-2018, 02:21 AM
Replies: 38
Views: 1,061
Posted By MN80Vette

FAST EZ 1.0 fouling plugs & O2 sensor

I installed a FAST EZ TBI EFI system 3 1/2 years ago that recently started fouling a set of spark plugs in ~50 miles and O2 sensors in ~100 miles, and it deposits black soot on the driveway or garage...
10-05-2018, 01:17 AM
Replies: 27
Views: 3,889
Posted By MN80Vette

It is still available tonight.

It is still available to tonight but it might not be available tomorrow afternoon. A C3 Forum member is going to test it and drive it home tomorrow morining if he's satisfied with it after a good...
09-29-2018, 11:28 AM
Replies: 7
Views: 340
Posted By MN80Vette

I should explain that I had to use 4" silicone...

I should explain that I had to use 4" silicone tubing because the Spectre 98499 single low profile plenum I used has a 4" inlet and the Vararam VR Power Duct fits inside 4" tubing too. I might still...
09-29-2018, 10:58 AM
Replies: 7
Views: 340
Posted By MN80Vette

Yes, I put an air bridge CAI on my '80 when I...

Yes, I put an air bridge CAI on my '80 when I installed a FAST EZ 1.0 EFI. It was a pretty straight forward mod using parts available on eBay and some angle iron and square tubing. I cut out part of...
09-18-2018, 09:04 PM
Replies: 27
Views: 3,889
Posted By MN80Vette

Thanks! AC would be a nice upgrade for much of...

Thanks!
AC would be a nice upgrade for much of the country, but you'd have to move the hard fuel lines to make room for the compressor. I don't know if Vintage Air or Classic Auto Air make a kit...
09-17-2018, 11:44 PM
Replies: 27
Views: 3,889
Posted By MN80Vette

Engine with Holley carb (pre-FAST EZ EFI), drop...

Engine with Holley carb (pre-FAST EZ EFI), drop base, K&N filter and lid.
Ported, ceramic coated Edelbrock RPM Air Gap, copper-nickel hard fuel lines, C5-like cold air intake...
09-17-2018, 11:18 PM
Replies: 27
Views: 3,889
Posted By MN80Vette

New diff, 360# composite rear spring, half...

New diff, 360# composite rear spring, half shafts, VB&P HD rear camber strut rods, 5/8" rear sway bar, Centerforce DF735552 Dual Friction street/strip clutch with hydraulic actuator. (Bilstein shocks...
Showing results 1 to 25 of 499
 


 
Forum Jump

Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.