CorvetteForum - Chevrolet Corvette Forum Discussion - Search Results

Search: Posts Made By: tacoamerica
Showing results 1 to 7 of 7
Search took 0.35 seconds.
Forum: C3 General
10-10-2006, 10:00 PM
Replies: 18
Views: 6,532
Posted By tacoamerica

:iagree: Mine's a 4-speed. Doesn't have it. --Taco

:iagree: Mine's a 4-speed. Doesn't have it. --Taco
Forum: C3 General
10-10-2006, 11:27 AM
Replies: 18
Views: 6,532
Posted By tacoamerica

Tristan, where is the switch and what does it...

Tristan, where is the switch and what does it look like? Taco :cool:
Forum: C3 General
09-29-2006, 11:15 AM
Replies: 18
Views: 6,532
Posted By tacoamerica

Great, that's what I'm getting ready to do. Two...

Great, that's what I'm getting ready to do. Two questions:

1. Was the assembly mounted under the firewall when you tack welded it, or did you adjust it, take it out, weld it, and put it back in?
...
Forum: C3 General
09-28-2006, 02:30 PM
Replies: 18
Views: 6,532
Posted By tacoamerica

Following up on that set pin... just saw another...

Following up on that set pin... just saw another lever assembly with the pin attached. The orientation is different.

The short end of the lever's U-bracket (where it connects to the pedal rod) is...
Forum: C3 General
09-27-2006, 03:45 PM
Replies: 18
Views: 6,532
Posted By tacoamerica

I'm glad you mentioned the set pin. Mine's gone,...

I'm glad you mentioned the set pin. Mine's gone, but the holes are there. I didn't see the holes in the Paragon lever. My mechanic said he'd tack weld the lever for me. I can put a replacement pin in...
Forum: C3 General
09-26-2006, 05:34 PM
Replies: 18
Views: 6,532
Posted By tacoamerica

Sounds like that may be it. When I push and pull...

Sounds like that may be it. When I push and pull the rod with my hand, it feels like it goes into position then slips out. That Paragon kit is what I was talking about buying. I'm going to take mine...
Forum: C3 General
09-25-2006, 11:24 PM
Replies: 18
Views: 6,532
Posted By tacoamerica

How can I fix my '69 accelerator pedal linkage?

The gas pedal on my '69 is flat on the floor, no travel, no gas. It had been going down gradually, then I adjusted my accelerator cable at the carburetor (thinking that was the problem) and the pedal...
Showing results 1 to 7 of 7


 
Forum Jump

Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.