C2 Quick Remove Rear Stingray Emblem - CorvetteForum - Chevrolet Corvette Forum Discussion



C1 & C2 Corvettes
General C1 Corvette & C2 Corvette Discussion, Technical Info, Performance Upgrades, Project Builds, Restorations
Sponsored by:
Sponsored by:

Quick Remove Rear Stingray Emblem

Reply
 
 
 
Thread Tools Search this Thread
Old 02-13-2017, 10:35 PM   #1
woodsdesign
CF Senior Member
Thread Starter
 
woodsdesign's Avatar
 
Member Since: Jan 2004
Location: Macedonia Ohio
Posts: 2,084
Thanked 12 Times in 11 Posts
Default Quick Remove Rear Stingray Emblem

Does anyone leave the speed nuts off the rear "Stingray" emblem?
I would like to be able to pull it off easily for buffing.
I thought I read somewhere that some guys use tape wrapped around the prongs to make it fit snug. Or, maybe it would just stay in the holes without the speed nuts.
I would like to hear suggestions.
woodsdesign is offline   Reply With Quote
The Following User Says Thank You to woodsdesign For This Useful Post:
Gofltn1 (02-14-2017)
Old 02-13-2017, 10:41 PM   #2
leif.anderson93
CF Senior Member
 
leif.anderson93's Avatar
 
Member Since: Feb 2014
Location: Richardson Texas
Posts: 1,154
Thanked 115 Times in 104 Posts
Default

Lawrence,
When my '67 was restored four years ago, I decided to not install the nuts on either the front (cross flags) or rear (StingRay) emblems. Makes it so much easier when waxing the car, pop them out and back in...no messy clean-up. They stay in there snug enough that I haven't had any issues. I don't use anything additional to hold them in place other than the paint that is already in the mounting holes. By the way, I drive this car about 5,000 miles per year...so, it's not like it just sits in the garage. Go for it

Last edited by leif.anderson93; 02-13-2017 at 10:42 PM.
leif.anderson93 is offline   Reply With Quote
Old 02-13-2017, 10:42 PM   #3
bluzrocker
CF Senior Member
 
bluzrocker's Avatar
 
Member Since: Feb 2011
Location: Dixon California
Posts: 1,247
Thanked 15 Times in 15 Posts
Default rear sting ray emblem

Tape will work...no nuts or tape can leave it loose and mar the paint during driving ....and for what your doing the tape on the prongs will work



Quote:
Originally Posted by woodsdesign View Post
Does anyone leave the speed nuts off the rear "Stingray" emblem?
I would like to be able to pull it off easily for buffing.
I thought I read somewhere that some guys use tape wrapped around the prongs to make it fit snug. Or, maybe it would just stay in the holes without the speed nuts.
I would like to hear suggestions.
bluzrocker is offline   Reply With Quote
The Following User Says Thank You to bluzrocker For This Useful Post:
Gofltn1 (02-14-2017)
Old 02-13-2017, 10:44 PM   #4
Daren67
CF Senior Member
 
Daren67's Avatar
 
Member Since: Feb 2006
Location: Old Greenwich CT
Posts: 396
Thanks: 0
Thanked 5 Times in 4 Posts
Default

Quote:
Originally Posted by leif.anderson93 View Post
Lawrence,
When my '67 was restored four years ago, I decided to not install the nuts on either the front (cross flags) or rear (StingRay) emblems. Makes it so much easier when waxing the car...no messy clean-up. They stay in there snug enough that I haven't had any issues. I don't use anything additional to hold them in place other than the paint that is already in the mounting holes. By the way, I drive this car about 5,000 miles per year...so, it's not like it just sits in the garage. Go for it
i agree. Except they were stolen when my car was getting a new top at a shop in bad neighborhood. But new ones were not bolted again . Never an issue. Pleasure to remove and wax all the time. Highly recommend
Daren67 is offline   Reply With Quote
Old 02-13-2017, 11:33 PM   #5
DONR
CF Senior Member
 
Member Since: Oct 2005
Location: AMARILLO TEXAS
Posts: 361
Thanks: 0
Thanked 14 Times in 8 Posts
Default Emblems

I do not have speednuts on my rear emblem. It really helps when buffing or waxing the car. I use a little 3m adhesive on the prongs. The emblem lifts off easy and seems to secure the emblem very well.

Don

Quote:
Originally Posted by woodsdesign View Post
Does anyone leave the speed nuts off the rear "Stingray" emblem?
I would like to be able to pull it off easily for buffing.
I thought I read somewhere that some guys use tape wrapped around the prongs to make it fit snug. Or, maybe it would just stay in the holes without the speed nuts.
I would like to hear suggestions.
DONR is offline   Reply With Quote
Old 02-14-2017, 09:41 PM   #6
Gofltn1
Junior Member
 
Gofltn1's Avatar
 
Member Since: Jan 2017
Location: Westminster CA
Posts: 32
Thanked 0 Times in 0 Posts
Default

Funny that this is an issue that arose on my "new" (for me anyway) 66 vert.first time on the freeway and my wife and I noticed something fly off from the front. Got home and it was the nose flag emblem. Gone. Anyway, ordered a new one and was wondering how to mount it so I don't lose one again. $50 repair that shouldn't have been necessary. Thanks Corvette Forum.
Gofltn1 is offline   Reply With Quote
Old 02-14-2017, 10:31 PM   #7
oldpainter
CF Senior Member
 
oldpainter's Avatar
 
Member Since: Feb 2010
Location: Lincoln Ne.
Posts: 445
Thanked 45 Times in 43 Posts
Default

I've been using some 3-M panel strip caulk on my rear emblem on my 67 for about 30 years. I just put on enough in areas that don't show and press it on. I take it off to wax all the time and replace the caulk when needed. I've never lost the emblem. Just enough tack to keep it in place.
oldpainter is offline   Reply With Quote
Old 02-15-2017, 02:05 PM   #8
67's
CF Senior Member
 
67's's Avatar
 
Member Since: Aug 2000
Location: POTSDAM NY
Posts: 5,902
Thanked 6 Times in 4 Posts
Default

Larry,
Put me in the no speed nuts used side, throw them in the wast bucket when was king, and reattach after.

Tom M
67's is offline   Reply With Quote
Old 02-15-2017, 02:31 PM   #9
randy ransome
CF Senior Member
C4 of Month Winner 2015
 
randy ransome's Avatar
 
Member Since: Nov 2004
Location: Olive Branch Mississippi
Posts: 1,860
Thanks: 0
Thanked 43 Times in 31 Posts
Default

I also use 3M double sided tape on mine.





randy ransome is offline   Reply With Quote
Old 02-15-2017, 09:00 PM   #10
woodsdesign
CF Senior Member
Thread Starter
 
woodsdesign's Avatar
 
Member Since: Jan 2004
Location: Macedonia Ohio
Posts: 2,084
Thanked 12 Times in 11 Posts
Default

Quote:
Originally Posted by Gofltn1 View Post
Funny that this is an issue that arose on my "new" (for me anyway) 66 vert.first time on the freeway and my wife and I noticed something fly off from the front. Got home and it was the nose flag emblem. Gone. Anyway, ordered a new one and was wondering how to mount it so I don't lose one again. $50 repair that shouldn't have been necessary. Thanks Corvette Forum.
Thanks for the response guys,
I had the same thing happen to me on a 96 Special Edition that I owned.
The front emblem blew off and hit the windshield. Scared the living **** out of me. That is the reason I put this out to you guys. These emblems arn't cheep.

Last edited by woodsdesign; 02-15-2017 at 09:03 PM.
woodsdesign is offline   Reply With Quote
The Following User Says Thank You to woodsdesign For This Useful Post:
Gofltn1 (02-15-2017)
Old 02-15-2017, 09:13 PM   #11
dcaggiani
CF Senior Member
 
dcaggiani's Avatar
 
Member Since: May 2012
Location: Boynton Beach FL
Posts: 715
Thanked 23 Times in 22 Posts
Default

I left the front emblem attached for the fear of what happened to woodsdesign
but the rear - much like the others who have chimed in - is not secured.
Have not had an issue in 4 years since it was done.
dcaggiani is offline   Reply With Quote
Old 02-15-2017, 10:06 PM   #12
mblake101
CF Senior Member
Support Corvetteforum!
 
mblake101's Avatar
 
Member Since: Mar 2010
Location: Bastrop Texas
Posts: 159
Thanked 5 Times in 5 Posts
Default Emblems

I had the same thing happen to me on my 67; the hood emblems flew up and off on the highway. Luckily, no paint damage to the hood. I use a couple of pencil erasers to hold down the emblems. No prob as yet.
mblake101 is offline   Reply With Quote
Old 02-15-2017, 11:38 PM   #13
65GGvert
CF Senior Member
 
65GGvert's Avatar
 
Member Since: Jul 2006
Location: Kannapolis NC
Posts: 12,335
Thanked 355 Times in 327 Posts
Default

Sting Ray
65GGvert is offline   Reply With Quote
Old 02-15-2017, 11:39 PM   #14
Gofltn1
Junior Member
 
Gofltn1's Avatar
 
Member Since: Jan 2017
Location: Westminster CA
Posts: 32
Thanked 0 Times in 0 Posts
Default

The emblem arrived but nothing to attach with, just the naked prongs. No speed nuts. What kind of tape used? Do you wrap it on before or after pushing the prongs in? How much do you use? I'm a novice so specificity please. Hard to get to if taping after pushing the prongs in.
Gofltn1 is offline   Reply With Quote
Old 02-16-2017, 12:17 AM   #15
still cruzin
CF Senior Member
 
still cruzin's Avatar
 
Member Since: Oct 2009
Location: Webster NY
Posts: 191
Thanked 6 Times in 4 Posts
Default

Restored my 67 about 20 years ago now. Never applied the speed nuts on the front or rear emblems! No tape, just slide them in. Never had a problem.

Bob

Last edited by still cruzin; 02-16-2017 at 12:19 AM.
still cruzin is offline   Reply With Quote
Old 02-16-2017, 12:31 AM   #16
bluzrocker
CF Senior Member
 
bluzrocker's Avatar
 
Member Since: Feb 2011
Location: Dixon California
Posts: 1,247
Thanked 15 Times in 15 Posts
Default nose badge

same thing here on new "trim Parts badge"....no threads on prongs...tried tape ..on the first part of the prongs...bout 1/2" not the entire prongs...pushed it in
still didn't feel like it was tight could lift it out with not much effort

...the cavity on the underside (where you would install the nuts)...if you had a badge with nut threads.... is to tight to do much after the badge is in all the wayso waiting for more suggestions from members

Quote:
Originally Posted by Gofltn1 View Post
The emblem arrived but nothing to attach with, just the naked prongs. No speed nuts. What kind of tape used? Do you wrap it on before or after pushing the prongs in? How much do you use? I'm a novice so specificity please. Hard to get to if taping after pushing the prongs in.
bluzrocker is offline   Reply With Quote
Old 02-16-2017, 01:29 AM   #17
66racer
CF Senior Member
Support Corvetteforum!
 
66racer's Avatar
 
Member Since: Apr 2005
Location: TU CUM CARI NEW.MEX.
Posts: 1,260
Thanked 8 Times in 8 Posts
Default

Quote:
Originally Posted by woodsdesign View Post
Does anyone leave the speed nuts off the rear "Stingray" emblem?
I would like to be able to pull it off easily for buffing.
I thought I read somewhere that some guys use tape wrapped around the prongs to make it fit snug. Or, maybe it would just stay in the holes without the speed nuts.
I would like to hear suggestions.
Best and easy way,cut about 1 inch or more of small i.d. hose that fits snug on prongs,easy on and off and will hold side emblems also
66racer
66racer is offline   Reply With Quote
The Following User Says Thank You to 66racer For This Useful Post:
bluzrocker (02-16-2017)
Old 02-16-2017, 02:28 AM   #18
bluzrocker
CF Senior Member
 
bluzrocker's Avatar
 
Member Since: Feb 2011
Location: Dixon California
Posts: 1,247
Thanked 15 Times in 15 Posts
Default how to hold badge on

Elmer...yer just the best...tx for the easy fix..


Quote:
Originally Posted by 66racer View Post
Best and easy way,cut about 1 inch or more of small i.d. hose that fits snug on prongs,easy on and off and will hold side emblems also
66racer
bluzrocker is offline   Reply With Quote
Old 02-16-2017, 09:02 AM   #19
Frankie the Fink
Hobbyist..
Support Corvetteforum!
 
Frankie the Fink's Avatar
 
Member Since: Aug 2007
Location: Winter Garden Florida
Posts: 34,261
Thanked 817 Times in 714 Posts
Default

I have a small soft brush that gets in the nooks and crannies of those emblems quite nicely during a buff up as they are secured with speed nuts. Easier than having airborne crossed flags or some spectator making off with an emblem. I did run off one little kid who was jerking back on a fender emblem like it was a Lego toy - it happens...
Frankie the Fink is offline   Reply With Quote
Old 02-16-2017, 12:17 PM   #20
Donny Brass
CF Senior Member
Support Corvetteforum!
 
Donny Brass's Avatar
 
Member Since: Sep 2004
Location: St. Clair Shores MI
Posts: 3,819
Thanked 45 Times in 31 Posts
Default

A forum member left all the speed nuts off his emblems...... I ran over his nose emblem on the drag strip and made a irreparable hole in a $200 tire............

mine are bolted on.... but I placed a small black nylon washer under each post and I can wax underneath them.
Donny Brass is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • [C2] Quick Remove Rear Stingray Emblem
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Emblem Mod faninc C7 General Discussion 21 07-03-2016 03:35 PM
    Need advice on removing emblems Beedub73 C3 General 7 05-07-2016 10:49 PM
    Emblem Mounting Capkunu C3 Tech/Performance 15 11-24-2013 08:44 PM
    Where to drill, emblem positions please! the-esses C3 Tech/Performance 1 03-04-2007 07:46 AM
    "Stingray" emblem adhesive 73, Dark Blue 454 C3 Tech/Performance 15 08-22-2006 09:01 AM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 06:41 AM.


     
    • Ask a Question
      Get answers from community experts
    What's your question?
    Send