Go Back   Corvette Forum > C3 Corvettes, 1968 - 1982 > C3 Tech/Performance
Sign in using an external account
Register Forgot Password?
Register Search Today's Posts Mark Forums Read FAQ Vendor Directory
Search
C3 Tech/Performance
V8 Technical Info, Internal Engine, External Engine, Basic Tech and Maintenance for the C3 Corvette Sponsored by
VBP

Welcome to Corvetteforum.com!
Welcome to Corvetteforum.com.

You are currently viewing our forum as a guest, which gives you limited access to view most discussions and access our other features. By joining our community, at no cost, you will have access to post topics, communicate privately with other members (PM), respond to polls, upload content and access many other special features. Registration is free, fast and simple, join Corvetteforum.com today!


Corvette Store
 
 
C7 Parts & Accessories
C6 Parts & Accessories
C5 Parts & Accessories
C4 Parts & Accessories
C3 Parts & Accessories
C2 Parts & Accessories
C1 Parts & Accessories
Wheels & Tires
Sponsored Ads
 
 
Vendor Directory
  
Reply
 
 
 
 
Thread Tools Search this Thread
Old 08-23-2011, 08:27 PM   #1
kj970
Junior Member
 
Member Since: Aug 2011
Default 1982 Crossfire Injection

I have an 82 with crossfire injection. It mainly sits in the garage and collects dust. The other day I started it up, for the first time in probably a year. It starts but will not idle or maintain a steady RPM. It will only rev up and then act like it's going to die unless you pump the gas and rev it back up. If you don't pump the gas it dies. The only way to keep it running is to basically keep pumping the gas pedal as it revs up and down.

Any ideas? clogged something perhaps?

any help appreciated
kj970 is offline   Reply With Quote
Old 08-23-2011, 08:34 PM   #2
terry82
CF Senior Member
 
Member Since: Jul 2000
Location: columbia city in
Default

turn off the lights and worry about it next year .your gas is probably bad.your fuel pump may be bad and or you may have a vac leak.
terry82 is offline   Reply With Quote
Old 08-23-2011, 09:59 PM   #3
7T1vette
CF Senior Member
 
7T1vette's Avatar
 
Member Since: Jan 2006
Location: Crossville TN
Default

Your car has an ECM with an on-board diagnostic system to guide you as to what is wrong. Does the "Check Engine" light (CEL) work? It should light when you turn the key to ON position (which indicates that the bulb still works). If the bulb is not burned out, and the ECM is still working, the OBD system should tell you (by its trouble codes) what the problem could be.
7T1vette is offline   Reply With Quote
Old 08-23-2011, 10:41 PM   #4
wombvette
CF Senior Member
 
wombvette's Avatar
 
Member Since: Jan 2000
Location: New Hill NC
Default

Worst thing you can possibly do is let a cross fire sit.
wombvette is offline   Reply With Quote
Old 08-24-2011, 12:44 AM   #5
cyclops1032
CF Senior Member
 
cyclops1032's Avatar
 
Member Since: Jul 2011
Location: Colorado City Texas
Default

Quote:
Originally Posted by kj970 View Post
I have an 82 with crossfire injection. It mainly sits in the garage and collects dust. The other day I started it up, for the first time in probably a year. It starts but will not idle or maintain a steady RPM. It will only rev up and then act like it's going to die unless you pump the gas and rev it back up. If you don't pump the gas it dies. The only way to keep it running is to basically keep pumping the gas pedal as it revs up and down.

Any ideas? clogged something perhaps?

any help appreciated
Sounds like the injectors are dirty (gummed up from sitting).
cyclops1032 is offline   Reply With Quote
Old 08-24-2011, 12:47 AM   #6
c3nashvette
CF Senior Member
Support Corvetteforum!
 
c3nashvette's Avatar
 
Member Since: Jul 2011
Location: LI NY
Default

My money is on bad gas/ low fuel pressure.
c3nashvette is offline   Reply With Quote
Old 08-24-2011, 08:47 AM   #7
wombvette
CF Senior Member
 
wombvette's Avatar
 
Member Since: Jan 2000
Location: New Hill NC
Default

All good suggestions, but idle air controls are a common cause of idle problems after sitting.
wombvette is offline   Reply With Quote
Old 08-25-2011, 12:00 AM   #8
couperdecar
CF Senior Member
 
couperdecar's Avatar
 
Member Since: Feb 2006
Location: Regina Saskatchewan
Default

I'd dump the year old gas , and clean it all with some Sea Foam. Lotta guys on here love the stuff.
couperdecar is offline   Reply With Quote
Old 08-25-2011, 12:23 AM   #9
leebay
CF Senior Member
 
leebay's Avatar
 
Member Since: Sep 2005
Location: Newport TN
Default

Your TPS Throttle Position Sensor could also be bad if the check engine light is on and reading either codes 21 or 22
leebay is offline   Reply With Quote
Old 10-10-2011, 09:02 PM   #10
Knighted1
Junior Member
 
Member Since: Oct 2011
Default

I just bought my first 82 with crossfire today, and it is doing the same thing, runs rough and wont idle. This one has been sitting for over a year...when I pulled it on the trailer, the valves were rattling as well...I am going to start with the old gas, and take it from there...then I am going to start following suggestions on here ....
Knighted1 is offline   Reply With Quote
Old 10-10-2011, 09:08 PM   #11
terry82
CF Senior Member
 
Member Since: Jul 2000
Location: columbia city in
Default

http://www.crossfire.homeip.net/index.php?act=idxthey have lots of info to read and can offer lots of advice.
terry82 is offline   Reply With Quote
Old 10-10-2011, 09:08 PM
 
Go Back   Corvette Forum > C3 Corvettes, 1968 - 1982 > C3 Tech/Performance
Reload this Page 1982 Crossfire Injection
 
 
 
Reply

Tags
1982, 2011, 82, corvette, crossfire, fast, forum, fourm, idle, injection, problems, running, stay, wont, works


Thread Tools Search this Thread
Search this Thread:

Click for Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are Off
Pingbacks are Off
Refbacks are Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Crossfire Injection and a TPI fuel pump KOO BOOM! Help!! sharkman76 C3 Tech/Performance 11 09-14-2014 07:47 AM
82 Crossfire Injection frankenbro C3 General 6 08-03-2014 07:12 PM
Hard to start C4 rsovine C4 Tech/Performance 11 10-08-2009 10:19 AM
several problems...one solution? nomomopars C3 Tech/Performance 6 08-12-2009 10:46 PM
Help on 84 auto... TK Projects C4 Tech/Performance 7 01-16-2003 10:11 PM


All times are GMT -4. The time now is 03:56 PM.


Emails & Password Backup