HUD not showing speed, only RPM - CorvetteForum - Chevrolet Corvette Forum Discussion

Register FAQ Search Today's Posts Mark Forums Read Vendor Directory

C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace Sponsored by
Dart Machinery

HUD not showing speed, only RPM

Reply
 
 
 
Thread Tools Search this Thread
Old 01-09-2010, 07:02 PM   #1
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default HUD not showing speed, only RPM

I just bought my 2003 Z06 about a month ago..the Heads up display was working fine, and now the other day the digital speed readout is gone, but the RPM's still show at the top.. Is this a fuse or bulb or does the entire unit have to be replaced??
DomZ06 is offline   Reply With Quote
Old 01-09-2010, 07:12 PM   #2
Blue 92
CF Senior Member
Support Corvetteforum!
CI 3-4, 8-9-10 Veteran
St. Jude Donor '06-'08-'10
 
Blue 92's Avatar
 
Member Since: May 1999
Location: Columbus Ohio
Posts: 22,820
Thanks: 0
Thanked 1 Time in 1 Post
Default

Did you try cycling through the different display options?
Blue 92 is offline   Reply With Quote
Old 01-09-2010, 08:07 PM   #3
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Blue 92 View Post
Did you try cycling through the different display options?
yea, i press the page button which used to change the other settings and nothing shows up except for the tach at the top/left side
DomZ06 is offline   Reply With Quote
Old 01-09-2010, 08:35 PM   #4
Blue 92
CF Senior Member
Support Corvetteforum!
CI 3-4, 8-9-10 Veteran
St. Jude Donor '06-'08-'10
 
Blue 92's Avatar
 
Member Since: May 1999
Location: Columbus Ohio
Posts: 22,820
Thanks: 0
Thanked 1 Time in 1 Post
Default

Did you try press and hold? Press and release cycles the gauges.

Page 3-18 here:

http://www.gmpartshouse.com/download...03corvette.pdf
Blue 92 is offline   Reply With Quote
Old 01-09-2010, 08:51 PM   #5
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by Blue 92 View Post
Did you try press and hold? Press and release cycles the gauges.

Page 3-18 here:

http://www.gmpartshouse.com/download...03corvette.pdf
Nope, didnt try that but im willing to guess thats what happened lol.. gonna go see if it works in a few mins
DomZ06 is offline   Reply With Quote
Old 01-10-2010, 01:37 AM   #6
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks man, that was what happened, i must have held the page button for a second too long..it works fine now
DomZ06 is offline   Reply With Quote
Old 01-10-2010, 01:43 AM   #7
Blue 92
CF Senior Member
Support Corvetteforum!
CI 3-4, 8-9-10 Veteran
St. Jude Donor '06-'08-'10
 
Blue 92's Avatar
 
Member Since: May 1999
Location: Columbus Ohio
Posts: 22,820
Thanks: 0
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by DomZ06 View Post
Thanks man, that was what happened, i must have held the page button for a second too long..it works fine now
Blue 92 is offline   Reply With Quote
Old 01-10-2010, 09:36 AM   #8
jrose7004
CF Senior Member
 
jrose7004's Avatar
 
Member Since: Mar 2004
Location: Oklahoma City OK
Posts: 52,452
Thanked 259 Times in 238 Posts
Default

Another case closed!
jrose7004 is online now   Reply With Quote
Old 01-10-2010, 11:24 AM   #9
schpenxel
CF Senior Member
Support Corvetteforum!
St. Jude Donor '15
 
schpenxel's Avatar
 
Member Since: May 2004
Location: Greensboro NC
Posts: 12,208
Thanked 434 Times in 412 Posts
Default

lol
schpenxel is offline   Reply With Quote
Old 06-21-2014, 10:13 PM   #10
Lt. Dan M.
CF Senior Member
Support Corvetteforum!
 
Lt. Dan M.'s Avatar
 
Member Since: Feb 2012
Location: Palm City Fl
Posts: 908
Thanks: 0
Thanked 1 Time in 1 Post
Default

I just had the same problem, read the link posted and went out to try it and sure enough that was all it was. This forum is AWESOME and so are its members! Thanks, once again.
Lt. Dan M. is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • HUD not showing speed, only RPM
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Z06 & ZR1 Transmission Gear Ratio mitchdb C6 Z06 Discussion 9 10-10-2015 07:17 PM
    What's my diferrential ratio? Mr Fufu C1 & C2 Corvettes 16 04-26-2015 08:26 PM
    Head Up display not "sticky" Jim Shearer C7 General Discussion 10 03-22-2015 12:08 AM
    75 vette rpm todd estal C3 General 7 09-22-2014 10:09 PM
    HUD & Oil Pressure Questions AZDANZ06 C6 Z06 Discussion 3 06-15-2014 05:52 PM


    Tags
    c6, corvette, hud, reflecting, showing, speed

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump


    All times are GMT -4. The time now is 07:55 PM.