Notices
C3 General General C3 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

Speedometer issue

 
Old 05-14-2019, 05:22 PM
  #1  
john szabo
Junior Member
Thread Starter
 
Member Since: May 2019
Posts: 1
Likes: 0
Received 0 Likes on 0 Posts
Default Speedometer issue

Speedometer stoppted working. It had been bouncing at 60 km for awhile. I took lower cable off and the the plastic end that fits in transducer had snapped off. The plastic end looks like it was a twisted break. I managed to drill the plastic end out of the transducer. I installed new cable into the transducer and spun the tranny end and spun freely. Hooked it up and drove 5km and it stopped working. The speedo was bouncing from the start before it stopped. Could it be the transducer? 1978 corvette

Last edited by john szabo; 05-14-2019 at 05:23 PM.
john szabo is offline  
Old 05-16-2019, 11:37 AM
  #2  
MelWff
CF Senior Member
 
MelWff's Avatar
 
Member Since: May 2006
Location: Danbury CT
Posts: 10,539
Received 641 Likes on 617 Posts
Default

did you check if the cable broke again at the same place?
MelWff is offline  
Old 05-17-2019, 06:54 AM
  #3  
Drifter36
CF Senior Member
 
Drifter36's Avatar
 
Member Since: Aug 2016
Location: Rockaway NJ
Posts: 183
Received 35 Likes on 32 Posts
Default

Quick guess is that your transducer internals are corroded and it’s not turning freely. Probably time for a replacement
Drifter36 is offline  

Thread Tools
Search this Thread
Quick Reply: Speedometer issue


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: