Notices
C3 General General C3 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

Help with Corvette not starting

 
Old 06-15-2019, 02:06 AM
  #1  
KibunInc
CF Senior Member
Thread Starter
 
KibunInc's Avatar
 
Member Since: Oct 2011
Location: Socal
Posts: 100
Likes: 0
Received 0 Likes on 0 Posts
Default Help with Corvette not starting

Hello. I tried to research this but couldn't find it here. I have a 1972 Corvette with a 350 CID and 4 speed manual trans. I was driving on the freeway and the car shut off. Towed it home. I have some mechanical experience. Car wont start now.

I have an electronic ignition with an external MSD coil. I noticed when I crank the engine I show power going to the negative side? Of the coil, it pulsates. I have spark. If i let the car sit a few minutes i no longer get power there or spark. Fuses test good with test light. What else should I check for the lack of power to the coil. Thanks
KibunInc is offline  
Old 06-15-2019, 11:25 AM
  #2  
Mooser
CF Senior Member
 
Member Since: Apr 2011
Location: Toronto Ontario
Posts: 5,620
Received 519 Likes on 449 Posts
Default

What elect-ign do you have?
M
Mooser is offline  
Old 06-15-2019, 12:03 PM
  #3  
KibunInc
CF Senior Member
Thread Starter
 
KibunInc's Avatar
 
Member Since: Oct 2011
Location: Socal
Posts: 100
Likes: 0
Received 0 Likes on 0 Posts
Default Help Corvette not starting.

Hello. I bought the car this way. Not sure of the brand of distributor but it no longer has points. I would call it a HEI with an external coil but not sure after that. I took the distributor cap off so I know it does not have point ignition. Thanks
KibunInc is offline  
Old 06-15-2019, 11:35 PM
  #4  
KibunInc
CF Senior Member
Thread Starter
 
KibunInc's Avatar
 
Member Since: Oct 2011
Location: Socal
Posts: 100
Likes: 0
Received 0 Likes on 0 Posts
Default

Bump for help
KibunInc is offline  
Old 06-15-2019, 11:39 PM
  #5  
Mooser
CF Senior Member
 
Member Since: Apr 2011
Location: Toronto Ontario
Posts: 5,620
Received 519 Likes on 449 Posts
Default

Can you put up a pic of the distributor so we can try to figure what it might be.
If it's an HEI, my first guess would be the module is gone/going and as soon as it heats up a little it quits completely
Anyway, would help to know what the distributor actually is to start
M
Mooser is offline  
Old 06-16-2019, 01:53 AM
  #6  
Bikespace
CF Senior Member
 
Bikespace's Avatar
 
Member Since: Mar 2017
Location: Northern Virginia
Posts: 1,884
Received 294 Likes on 275 Posts
Default

HEI with external coil, so perhaps a points to solid-state conversion? Please take a photo under the cap, too. I'm guessing a Pertronix ignitor or equivalent. They can fail abruptly, but are easy to fix/replace.

Last edited by Bikespace; 06-16-2019 at 01:54 AM.
Bikespace is offline  
Old 06-16-2019, 02:35 AM
  #7  
KibunInc
CF Senior Member
Thread Starter
 
KibunInc's Avatar
 
Member Since: Oct 2011
Location: Socal
Posts: 100
Likes: 0
Received 0 Likes on 0 Posts
Default

Thanks for the replies. I will take a photo and post it.
KibunInc is offline  
 


Thread Tools
Search this Thread
Quick Reply: Help with Corvette not starting


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: