Z06 Check engine light cause no cruise? - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C6 Corvette ZR1 & Z06 General info about GMs Corvette Supercar, LS9 Corvette Technical Info, Performance Upgrades, Suspension Setup for Street or Track Advertisement
Sponsored by:
Sponsored by:

[Z06] Check engine light cause no cruise?

Old 10-03-2011, 12:49 PM
  #1  
USCGREEL
CF Senior Member
Thread Starter
 
USCGREEL's Avatar
 
Member Since: Aug 2008
Location: Orlando Area FL
Posts: 271
Thanks: 0
Thanked 0 Times in 0 Posts
Default Check engine light cause no cruise?

Will a active check engine light cause my cruise control not to work? The check engine light is on because of no cats, and I am waiting to get a tune to clear it.
USCGREEL is offline  
Old 10-03-2011, 07:18 PM
  #2  
haljensen
CF Senior Member
Support Corvetteforum!
 
haljensen's Avatar
 
Member Since: Mar 2005
Location: Austin Texas
Posts: 10,399
Thanks: 0
Thanked 5 Times in 5 Posts
Default

Originally Posted by USCGREEL View Post
Will a active check engine light cause my cruise control not to work? The check engine light is on because of no cats, and I am waiting to get a tune to clear it.
Is the CEL only from the no cats or do you have other codes also? Various other codes could affect the Cruise.
haljensen is offline  
Old 10-03-2011, 09:00 PM
  #3  
USCGREEL
CF Senior Member
Thread Starter
 
USCGREEL's Avatar
 
Member Since: Aug 2008
Location: Orlando Area FL
Posts: 271
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Yeah the code is only for the O2's, I was just curious if anyone knew that this effects it or not. I just didn't want to start tearing things apart then come to find out it was the code doing it the whole time. Apparently it quit working after BPP worked on it (from the previous owner) and they did heads, cam, tune, and whatever else they do and thats when it quit working.
USCGREEL is offline  
Old 02-25-2012, 11:23 PM
  #4  
USCGREEL
CF Senior Member
Thread Starter
 
USCGREEL's Avatar
 
Member Since: Aug 2008
Location: Orlando Area FL
Posts: 271
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Anyone?
USCGREEL is offline  
Old 02-27-2012, 10:12 PM
  #5  
My07C6
CF Senior Member
 
My07C6's Avatar
 
Member Since: Mar 2007
Location: KC KS
Posts: 338
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I have heard of broken clutch pedal assist spring not letting the clutch pedal all the way up causing the cruise control not to work.
My07C6 is offline  
Old 05-19-2012, 07:26 PM
  #6  
USCGREEL
CF Senior Member
Thread Starter
 
USCGREEL's Avatar
 
Member Since: Aug 2008
Location: Orlando Area FL
Posts: 271
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Found the problem during a clutch master cylinder replacement, it was the top/return clutch sensor...what a easy fix..
USCGREEL is offline  
Old 05-19-2012, 10:21 PM
  #7  
My07C6
CF Senior Member
 
My07C6's Avatar
 
Member Since: Mar 2007
Location: KC KS
Posts: 338
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by USCGREEL View Post
Found the problem during a clutch master cylinder replacement, it was the top/return clutch sensor...what a easy fix..
Is't that what I said?
My07C6 is offline  
Old 05-21-2012, 03:38 AM
  #8  
USCGREEL
CF Senior Member
Thread Starter
 
USCGREEL's Avatar
 
Member Since: Aug 2008
Location: Orlando Area FL
Posts: 271
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by My07C6 View Post
I have heard of broken clutch pedal assist spring not letting the clutch pedal all the way up causing the cruise control not to work.
You mentioned the clutch return spring, that was fine, I actually took the spring out of the car and no longer use it.
USCGREEL is offline  
Old 05-21-2012, 08:30 AM
  #9  
My07C6
CF Senior Member
 
My07C6's Avatar
 
Member Since: Mar 2007
Location: KC KS
Posts: 338
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Originally Posted by USCGREEL View Post
You mentioned the clutch return spring, that was fine, I actually took the spring out of the car and no longer use it.
Sorry, I guess I wasn't clear. The key to the sentence was "not letting the clutch pedal all the way up" referring to the upper clutch pedal switch not making.
My07C6 is offline  


Thread Tools
Search this Thread
Quick Reply: [Z06] Check engine light cause no cruise?


Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: