Radio - CorvetteForum - Chevrolet Corvette Forum Discussion


C7 General Discussion
General C7 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

Radio

Reply
 
 
 
Thread Tools Search this Thread
Old 02-16-2017, 05:42 PM   #1
rkhegler
CF Senior Member
Thread Starter
 
rkhegler's Avatar
 
Member Since: Mar 2004
Location: Big Red Ne
Posts: 28,798
Thanked 318 Times in 126 Posts
Default Radio

Beautiful day here in Nebraska. Decided to take my C7 Stingray for a little ride to do some shopping. After shopping was finished, I got into the car to return home, the Radio did not work. All of the screen components displayed information and seemed to work just fine. I stopped the car, let it set for a couple of minutes and restarted the ignition. Nothing! Drove home (about 20 miles in silence). Pulled into the drive way and tried to read the owner's manual. Nothing on how to reprogram the radio. Called the dealership and they were "too busy" to come to the phone. So, I decided to pull the car into the garage. Presto, the radio came on.

Anyone have a clue as to what happened? Did I inadvertently press some button? Thanks.
rkhegler is offline   Reply With Quote
Old 02-16-2017, 05:50 PM   #2
C7-Vette
CF Senior Member
 
C7-Vette's Avatar
 
Member Since: Jul 2004
Location: Wantagh,L.I. New York
Posts: 3,226
Thanked 18 Times in 16 Posts
Default

Quote:
Originally Posted by rkhegler View Post
Beautiful day here in Nebraska. Decided to take my C7 Stingray for a little ride to do some shopping. After shopping was finished, I got into the car to return home, the Radio did not work. All of the screen components displayed information and seemed to work just fine. I stopped the car, let it set for a couple of minutes and restarted the ignition. Nothing! Drove home (about 20 miles in silence). Pulled into the drive way and tried to read the owner's manual. Nothing on how to reprogram the radio. Called the dealership and they were "too busy" to come to the phone. So, I decided to pull the car into the garage. Presto, the radio came on.

Anyone have a clue as to what happened? Did I inadvertently press some button? Thanks.
If it should happen again, just disconnect the negative terminal on the battery for a minute or so. Why it happens... you got me!
C7-Vette is offline   Reply With Quote
Old 02-16-2017, 05:54 PM   #3
Hoonose
CF Senior Member
 
Hoonose's Avatar
 
Member Since: Feb 2000
Location: Arizona
Posts: 39,089
Thanked 42 Times in 38 Posts
Default

Quote:
Originally Posted by rkhegler View Post
Beautiful day here in Nebraska. Decided to take my C7 Stingray for a little ride to do some shopping. After shopping was finished, I got into the car to return home, the Radio did not work. All of the screen components displayed information and seemed to work just fine. I stopped the car, let it set for a couple of minutes and restarted the ignition. Nothing! Drove home (about 20 miles in silence). Pulled into the drive way and tried to read the owner's manual. Nothing on how to reprogram the radio. Called the dealership and they were "too busy" to come to the phone. So, I decided to pull the car into the garage. Presto, the radio came on.

Anyone have a clue as to what happened? Did I inadvertently press some button? Thanks.
On my 2017 you can mute the radio by pressing in the volume button.
Hoonose is offline   Reply With Quote
Old 02-16-2017, 06:07 PM   #4
budgreen3564
CF Senior Member
Support Corvetteforum!
 
budgreen3564's Avatar
 
Member Since: Nov 2007
Location: parker texas retired police DPD Sergeant
Posts: 2,688
Thanked 115 Times in 80 Posts
Default

When muted, I think it stays muted upon restart.
budgreen3564 is offline   Reply With Quote
Old 02-16-2017, 06:15 PM   #5
nytrorcr
CF Senior Member
 
nytrorcr's Avatar
 
Member Since: Nov 2012
Location: Cookeville TN
Posts: 549
Thanked 82 Times in 57 Posts
Default Radio

Quote:
Originally Posted by C7-Vette View Post
If it should happen again, just disconnect the negative terminal on the battery for a minute or so. Why it happens... you got me!
The above statement works for many of those weird why did this stop working..........
nytrorcr is offline   Reply With Quote
The Following User Says Thank You to nytrorcr For This Useful Post:
Rebel Yell (02-17-2017)
Old 02-16-2017, 06:21 PM   #6
Old Goat MN
Junior Member
 
Member Since: Feb 2017
Location: Newport MN
Posts: 45
Thanked 18 Times in 8 Posts
Default

my 2016 had a glitch with how many stations you could pre program and also it acted funny. Took it back to the dealer and they replaced the radio with new one. Not sure but there may be a tech bulletin about it since they really didn't even discuss it they just replaced it.
Old Goat MN is offline   Reply With Quote
Old 02-16-2017, 06:27 PM   #7
rkhegler
CF Senior Member
Thread Starter
 
rkhegler's Avatar
 
Member Since: Mar 2004
Location: Big Red Ne
Posts: 28,798
Thanked 318 Times in 126 Posts
Default

Quote:
Originally Posted by Hoonose View Post
On my 2017 you can mute the radio by pressing in the volume button.
Tried that with no success. I will wait until until tomorrow and see if it malfunctions again.
rkhegler is offline   Reply With Quote
Old 02-16-2017, 06:48 PM   #8
NSC5
CF Senior Member
Support Corvetteforum!
 
NSC5's Avatar
 
Member Since: Aug 2012
Posts: 3,223
Thanked 649 Times in 461 Posts
Default

My 2008 CTS used to do this about one time out of 20 when using the remote start; a restart would cure it. My 2014 ATS has done this about 3 times in the three years I have owned it. My 2016 Z06 hasn't had this issue yet but I am sure at some point it will. There is a lot of stuff going on at startup and all it takes is one little electronic glitch for a module not to initialize properly.

These types of glitches are one of the reasons I am not enamored with the whole self-driving car concept. Like most others I have experienced glitches with much simpler PCs, Iphones, etc. and the only thing more difficult than figuring out what caused the glitch AFTER it happens is predicting all environmental interactions that could cause such a failure BEFORE it happens. That level of reliability at a practical price point for a mass consumption product will be an interesting bit of magic.
NSC5 is offline   Reply With Quote
Old 02-16-2017, 09:29 PM   #9
vbdenny
CF Senior Member
 
vbdenny's Avatar
 
Member Since: Jul 2016
Location: Virginia Beach Virginia
Posts: 1,233
Thanked 296 Times in 220 Posts
Default

There is a radio in these? Stupid exhaust hasn't let me use it.
vbdenny is offline   Reply With Quote
Old 02-16-2017, 09:38 PM   #10
owc6
CF Senior Member
 
owc6's Avatar
 
Member Since: Apr 2013
Location: Broomes Island, MD
Posts: 11,091
Thanked 1,233 Times in 911 Posts
Default

Was the radio on XM?

If so, try setting the channel to 1 or 0.
owc6 is offline   Reply With Quote
Old 02-17-2017, 02:00 PM   #11
rkhegler
CF Senior Member
Thread Starter
 
rkhegler's Avatar
 
Member Since: Mar 2004
Location: Big Red Ne
Posts: 28,798
Thanked 318 Times in 126 Posts
Default

Drove the car this morning and the radio worked fine. Don't know what the problem was. Anyway, thanks for all who chimed in with advice.
rkhegler is offline   Reply With Quote
Old 02-17-2017, 06:51 PM   #12
Always Red Dave
CF Senior Member
 
Always Red Dave's Avatar
 
Member Since: Oct 2005
Location: Plymouth Massachusetts
Posts: 5,890
Thanked 627 Times in 472 Posts
Default

Quote:
Originally Posted by rkhegler View Post
Drove the car this morning and the radio worked fine. Don't know what the problem was. Anyway, thanks for all who chimed in with advice.
GREMLINS!

Last edited by Always Red Dave; 02-17-2017 at 06:53 PM.
Always Red Dave is offline   Reply With Quote
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Radio
  •  
     
    Reply

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Radio Works but No Sound srtrich Audio/Electronics 25 08-16-2016 10:42 PM
    Electrical Problems... Richard Cooper C3 General 20 06-22-2016 07:46 PM
    Puzzled! I pulled every fuse from under the hood and cant disconnect the radio 2006 silver z06 C6 Corvette General Discussion 5 06-15-2016 03:34 PM
    Radio Presets Lost SUPERCRUZ C5 Tech 14 12-21-2015 08:13 PM
    Radio Stuck on cassette. Custom Autosound USA1 shtglouie C3 Tech/Performance 2 10-15-2015 05:37 PM


    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump

    Sponsored Ads
    Vendor Directory

    All times are GMT -4. The time now is 05:00 PM.


     
    • Ask a Question
      Get answers from community experts
    Question Title:
    Description:
    Your question will be posted in: