Notices
C7 General Discussion General C7 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

Stingray ride quality

 
Old 01-15-2019, 08:08 PM
  #1  
Dewayne4608
CF Member
Thread Starter
 
Member Since: Aug 2014
Posts: 69
Thanked 5 Times in 5 Posts
Default Stingray ride quality

Hey guys,

my new to me 2014 z51 2lt stingray with mag ride, rides like crap trying to figure out the cause. The car has 325/25/20 rears, 28k miles and feels like a tin can driving. I must admit its 35 degrees out and know that makes a difference but I drove a 2017 z06 at the same time and it felt amazing. What steps should I take first to diagnose the bad ride quality. Pretty sure the car was beat on but shes mine now so any advice I'd appreciate.

thanks peeps...
Dewayne4608 is offline  
Old 01-15-2019, 08:14 PM
  #2  
KenHorse
Obama, the worst POS ever
Support Corvetteforum!
 
KenHorse's Avatar
 
Member Since: Aug 2007
Location: Aurora, OR by way of Maui, HI. I have the heart of a Progressive - I keep it in a jar on my desk
Posts: 101,716
Thanked 651 Times in 441 Posts
St. Jude Donor '11-'12-'13, '16-'17-'18
Default

In Tour?
KenHorse is online now  
Old 01-15-2019, 08:20 PM
  #3  
wlittle49
CF Senior Member
 
Member Since: Apr 2018
Location: Chiggerbranch, MS
Posts: 127
Thanked 34 Times in 22 Posts
Default

I have a non Z51 2014 Stingray which did not have mag ride as an option. The ride is really good and I know there is a mag ride software update at the dealer for about $350. We don't have the same suspension but I would sure look into the shocks and the mag ride update.
wlittle49 is offline  
Old 01-15-2019, 08:29 PM
  #4  
c54u
CF Senior Member
 
c54u's Avatar
 
Member Since: Aug 2006
Posts: 2,080
Thanked 371 Times in 277 Posts
Default

Make sure you still have mag ride shocks seeing the car was previously owned. Open the hood and the two front shocks should be black and should have a wire coming out of them. Harder to check the rear ones, but they should be black as well. Check your tire pressure to be 30-32 psi. Those 325's are very wide and would probably hit or rub the rear fenders.

Last edited by c54u; 01-15-2019 at 08:29 PM.
c54u is offline  
Old 01-15-2019, 09:01 PM
  #5  
Dewayne4608
CF Member
Thread Starter
 
Member Since: Aug 2014
Posts: 69
Thanked 5 Times in 5 Posts
Default

I checked it does have mag ride.. The car for real rides about yhe same or slightly worse than my 2011 C6 Grandsport and feels totally different than the z06 I rode. The z06 fept very smooth planted and like a new car should. Im almost positive this is not how the car is supposed to feel. a car with 28k miles driven hard what would make this happen? also I notice interior body noise creaking etc. seems about the same as my C6 but thought the c7 got rid of alot of this body roll feeling.
Dewayne4608 is offline  
Old 01-15-2019, 09:08 PM
  #6  
Skid Row Joe
CF Senior Member
 
Skid Row Joe's Avatar
 
Member Since: Sep 2010
Location: Dallas, Texas - Make America Great Again!
Posts: 13,792
Thanked 993 Times in 787 Posts
Default

There's also an aftermarket supplier of MSRC ride quality upgrading available for your 2014.
Skid Row Joe is offline  
Old 01-15-2019, 09:12 PM
  #7  
Skid Row Joe
CF Senior Member
 
Skid Row Joe's Avatar
 
Member Since: Sep 2010
Location: Dallas, Texas - Make America Great Again!
Posts: 13,792
Thanked 993 Times in 787 Posts
Default

Interior body noise creaking from what areas? If you've got the hatchback with the removable solid topper, that could be one of the sources.
Skid Row Joe is offline  
Old 01-15-2019, 09:20 PM
  #8  
BrunoTheMellow
CF Senior Member
 
BrunoTheMellow's Avatar
 
Member Since: Jan 2015
Posts: 1,883
Thanked 293 Times in 231 Posts
Default

Z51 should ride real soft and smooth, almost too soft. Compared to the Z06 , the front should be slightly more bouncy and tramline less.

Do you mean rough like it feels like you're hitting potholes and loud hits? Like if you're riding on zero sidewalls? Or jarry like if the suspension is stupid stiff.

Last edited by BrunoTheMellow; 01-15-2019 at 09:23 PM.
BrunoTheMellow is offline  
Old 01-15-2019, 09:42 PM
  #9  
Dewayne4608
CF Member
Thread Starter
 
Member Since: Aug 2014
Posts: 69
Thanked 5 Times in 5 Posts
Default

it feel the the car is riding on metap tires. super stiff and the the car feels like Im driving a 72 nova instead of a 2014 car. u know how when u drove a new car the suspension is tight and everything seems like a new car. at 32k miles my m6 still felt that way. this car feels like there is no suspension at all and the frame is from the 70s. thats about the only way i can describe it.
Dewayne4608 is offline  
Old 01-15-2019, 10:19 PM
  #10  
Avanti
CF Senior Member
 
Avanti's Avatar
 
Member Since: Mar 2001
Location: Bonneville Salt Flats, 223mph Aug. '04
Posts: 5,690
Thanked 563 Times in 405 Posts
Default

Which specific tires do you have? Some (summer tires) are not meant to be driven in the cold. I've never done so with mine, but I'd suspect the ride might suffer as much as the tires often do... just saying...

Also, what I found with my '18 when I picked up at Kerbeck's was how much better the current runflats ride than the old Goodyears that came on my C5 (and, are still out in a shed somewhere ) So, bottom-line is, of course, that ride-comfort is greatly subjective.
Avanti is offline  
Old 01-15-2019, 10:24 PM
  #11  
TriPinTaZ
CF Senior Member
 
TriPinTaZ's Avatar
 
Member Since: Mar 2004
Posts: 1,527
Thanked 131 Times in 97 Posts
Default

Those big rear tires are probably an issue. Are the fronts wider than normal as well? Oversize wheels will make the car ride like garbage.
TriPinTaZ is offline  
Old 01-15-2019, 10:26 PM
  #12  
Dewayne4608
CF Member
Thread Starter
 
Member Since: Aug 2014
Posts: 69
Thanked 5 Times in 5 Posts
Default

michelin super sport 325/25/20.

If i didnt own a 2011 Grandsport and have driven that 17 z06 side by side id probably think its just how it is but i know a 14 c7 has to ride better than a 2011 grand sport. they both have the same tires on them. Maybe Ill take it in and have em check the suspension..
Dewayne4608 is offline  
Old 01-15-2019, 10:26 PM
  #13  
Dewayne4608
CF Member
Thread Starter
 
Member Since: Aug 2014
Posts: 69
Thanked 5 Times in 5 Posts
Default

Originally Posted by TriPinTaZ View Post
Those big rear tires are probably an issue. Are the fronts wider than normal as well? Oversize wheels will make the car ride like garbage.
yes the fronts are wider too.
Dewayne4608 is offline  
Old 01-15-2019, 10:37 PM
  #14  
jtranger
CF Senior Member
 
jtranger's Avatar
 
Member Since: Nov 2006
Location: Anaheim California
Posts: 2,145
Thanked 74 Times in 58 Posts
Default

Do you have the A8? Possible shudder? Feel like you are driving over pebbles?
jtranger is offline  
Old 01-15-2019, 10:40 PM
  #15  
65fastback
CF Senior Member
 
65fastback's Avatar
 
Member Since: Mar 2018
Posts: 330
Thanked 105 Times in 75 Posts
Default

Originally Posted by Dewayne4608 View Post
Hey guys,

my new to me 2014 z51 2lt stingray with mag ride, rides like crap trying to figure out the cause. The car has 325/25/20 rears, 28k miles and feels like a tin can driving. I must admit its 35 degrees out and know that makes a difference but I drove a 2017 z06 at the same time and it felt amazing. What steps should I take first to diagnose the bad ride quality. Pretty sure the car was beat on but shes mine now so any advice I'd appreciate.

thanks peeps...

Sorry but....Why did you buy it if it rides like crap?
65fastback is offline  
The Following User Says Thank You to 65fastback For This Useful Post:
Woodson (01-16-2019)
Old 01-15-2019, 10:42 PM
  #16  
LuisZ51
CF Senior Member
 
LuisZ51's Avatar
 
Member Since: Jan 2019
Location: Lake Placid, FL
Posts: 187
Thanks: 0
Thanked 30 Times in 24 Posts
Default

There's a video on YouTube that talks about a "hidden" magnetic ride control menu. I tried it and it made my Z51 ride softer.
You pretty much put the car into track mode then double tap the center button in the mode selector. That brings the different settings up in the gauge cluster info. I set mine to wet and the ride gets softer.

Last edited by LuisZ51; 01-15-2019 at 10:49 PM.
LuisZ51 is offline  
Old 01-15-2019, 10:49 PM
  #17  
Skid Row Joe
CF Senior Member
 
Skid Row Joe's Avatar
 
Member Since: Sep 2010
Location: Dallas, Texas - Make America Great Again!
Posts: 13,792
Thanked 993 Times in 787 Posts
Default

Originally Posted by Dewayne4608 View Post
it feel the the car is riding on metap tires. super stiff and the the car feels like Im driving a 72 nova instead of a 2014 car. u know how when u drove a new car the suspension is tight and everything seems like a new car. at 32k miles my m6 still felt that way. this car feels like there is no suspension at all and the frame is from the 70s. thats about the only way i can describe it.
I know exactly what you're talking about now. The MSRC GM Factory reprogramming upgrade may not have been done to your used 2014. Check with your Chevrolet dealer. There might be too much air pressure in your tires. That can cause what you're feeling too.
Skid Row Joe is offline  
Old 01-15-2019, 10:49 PM
  #18  
rrsperry
CF Senior Member
 
rrsperry's Avatar
 
Member Since: Sep 2015
Posts: 2,564
Thanked 386 Times in 250 Posts
Default

Since when is PTM in any way hidden? Wow...

OP, check with your dealer and get the $350 MRC software update. Consider getting the correct size tires.

my Z51 rides great.
rrsperry is offline  
The Following User Says Thank You to rrsperry For This Useful Post:
Woodson (01-16-2019)
Old 01-15-2019, 10:53 PM
  #19  
Dewayne4608
CF Member
Thread Starter
 
Member Since: Aug 2014
Posts: 69
Thanked 5 Times in 5 Posts
Default

Originally Posted by 65fastback View Post
Sorry but....Why did you buy it if it rides like crap?
Cause its the best looking stingray Ive ever seen. guy did a wide body kit, skirts added 4k in wheels on it that looks wider than a z06 and tough as hell. . it came certified and an afyermarket 5 year warranty so I said Ill figure out why it rides crappy later so here I am. lol
Dewayne4608 is offline  
Old 01-15-2019, 10:54 PM
  #20  
Dewayne4608
CF Member
Thread Starter
 
Member Since: Aug 2014
Posts: 69
Thanked 5 Times in 5 Posts
Default

Originally Posted by Skid Row Joe View Post
I know exactly what you're talking about now. The MSRC GM Factory reprogramming upgrade may not have been done to your used 2014. Check with your Chevrolet dealer. There might be too much air pressure in your tires. That can cause what you're feeling too.
awesome thx....
Dewayne4608 is offline  

Thread Tools
Search this Thread
Quick Reply: Stingray ride quality


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: