Notices
C7 General Discussion General C7 Corvette Discussion not covered in Tech
Sponsored by:
Sponsored by:

HUD is missing a segment

 
Old 06-09-2019, 01:31 PM
  #1  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default HUD is missing a segment

The hud display just started missing a segment. To explain, part of the tachometer arc is missing inbetween 5000 and 6000 rpms, as well as part of the number 5. If you rev past 5000 rpm, the rpm band disappears in that section.
Anybody had something similar? Bad ribbon cable or new HUD?
Near Miss is offline  
Old 06-09-2019, 01:45 PM
  #2  
owc6
CF Senior Member
 
owc6's Avatar
 
Member Since: Apr 2013
Location: Broomes Island, MD
Posts: 15,788
Received 2,682 Likes on 1,838 Posts
Default

Back in '14, I had the center of the HUD disappear for about ten minutes then slowly reappear. Has never happened again (knock wood).
owc6 is offline  
Old 06-09-2019, 01:47 PM
  #3  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default

Sounds similar, except it has not come back.
Near Miss is offline  
Old 06-09-2019, 05:49 PM
  #4  
Vetteman Jack
Moderator
Support Corvetteforum!
 
Vetteman Jack's Avatar
 
Member Since: Mar 2001
Location: Missouri. Currently own 2014 Stingray Coupe.
Posts: 271,302
Received 4,463 Likes on 3,833 Posts
MO Events Coordinator
St. Jude Co-Organizer
St. Jude Donor '03-'04-'05-'06-'07-'08-'09-'10-'11-'12-'13-'14-'15-'16-'17-'18-'19
NCM Sinkhole Donor
CI 5, 8 & 11 Veteran

Default

I have not seen that problem on mine, but if you find out what the issue is and the cure, please post it up.
Vetteman Jack is online now  
The following users liked this post:
Skid Row Joe (06-10-2019)
Old 06-09-2019, 05:51 PM
  #5  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default

Will do.
Near Miss is offline  
Old 06-09-2019, 08:02 PM
  #6  
Grand Slam
CF Senior Member
 
Grand Slam's Avatar
 
Member Since: Oct 2004
Location: Sunnyvale CA
Posts: 1,098
Received 147 Likes on 114 Posts
Default

Disconnect the battery for a few minutes and then reconnect which will reset all the electronics. Re-indes the windows afterward.
Grand Slam is offline  
Old 06-09-2019, 08:07 PM
  #7  
Maxie2U
CF Senior Member
 
Maxie2U's Avatar
 
Member Since: Aug 2015
Location: Portland Oregon
Posts: 3,999
Received 1,290 Likes on 836 Posts
Default

When asking a question about something visual it is alway good to post a picture.
Maxie2U is offline  
Old 06-10-2019, 10:24 AM
  #8  
Gvnski
CF Senior Member
 
Gvnski's Avatar
 
Member Since: Feb 2015
Location: Granbury Texas
Posts: 235
Received 51 Likes on 37 Posts
Default

Maybe you have the height adjusted too low and below the projection band.
Gvnski is offline  
The following users liked this post:
repo czar (06-10-2019)
Old 06-10-2019, 10:30 AM
  #9  
1SG_Ret
CF Senior Member
 
1SG_Ret's Avatar
 
Member Since: Jul 2014
Location: Bonita Springs Florida
Posts: 1,917
Received 288 Likes on 196 Posts
Default

Originally Posted by Gvnski View Post
Maybe you have the height adjusted too low and below the projection band.
A buddy with a 2015 3LT had a similar issue. His HUD was canted and the edge was missing. Dealership adjusted it for him. If you are on good terms w/ with svc mgr, you could stop in ask the question and show him.
1SG_Ret is offline  
Old 06-10-2019, 11:47 AM
  #10  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default

I tried moving the hud up and down with no results. Had an issue with the "reduced power" so I have an appointment for that issue today as well as looking at the HUD. Did not want to try the battery reset until the code was pulled.
Historical codes are supposed to stay in with a battery reset, but did not want to take the chance.
Near Miss is offline  
Old 06-10-2019, 01:34 PM
  #11  
Casey Clark
CF Member
 
Casey Clark's Avatar
 
Member Since: Jan 2019
Location: Sanger, Tx
Posts: 70
Received 13 Likes on 13 Posts
Default

I doubt this is the issue but I would check the glass behind the wheel (on the dash) and make sure there is not like a parking receipt or something covering part of the hud projector lens. I actually cleaned that glass when I first bought my car (used) and apparently the previous owner never cleaned it because it made my HUD a ton brighter.
Casey Clark is offline  
Old 06-10-2019, 03:25 PM
  #12  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default

Originally Posted by Casey Clark View Post
I doubt this is the issue but I would check the glass behind the wheel (on the dash) and make sure there is not like a parking receipt or something covering part of the hud projector lens. I actually cleaned that glass when I first bought my car (used) and apparently the previous owner never cleaned it because it made my HUD a ton brighter.
I thought of that too, and looked to the best of my ability. Could not find anything, but you never know.
Near Miss is offline  
Old 06-10-2019, 05:21 PM
  #13  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default


Missing segment at 2 o'clock
Near Miss is offline  
Old 06-10-2019, 05:25 PM
  #14  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default

What is peculiar is, the '5' is now whole.
Near Miss is offline  
Old 06-12-2019, 03:12 PM
  #15  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default

Dealer determined that part of the line that projects the image is not lit. The HUD is being replaced. The gmepp warranty has now paid for itself
Near Miss is offline  
The following users liked this post:
Maxie2U (06-12-2019)
Old 06-12-2019, 06:51 PM
  #16  
Bradysdad
CF Senior Member
 
Bradysdad's Avatar
 
Member Since: Jun 2009
Location: Hartland WI
Posts: 461
Received 69 Likes on 44 Posts
Default

Was it just missing from that view or from all view options?
Bradysdad is offline  
Old 06-12-2019, 07:39 PM
  #17  
Near Miss
CF Senior Member
Thread Starter
 
Member Since: Feb 2005
Location: Raleigh North Carolina
Posts: 148
Received 9 Likes on 9 Posts
Default

Originally Posted by Bradysdad View Post
Was it just missing from that view or from all view options?
Parts were missing in every selection except the screen that only displayed speed. The speed was outside the dead area.
Not looking forward to them removing the dash.
Near Miss is offline  

Thread Tools
Search this Thread
Quick Reply: HUD is missing a segment


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: