ECM Question - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C4 Tech/Performance L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

ECM Question

Old 04-16-2018, 01:26 PM
  #1  
Signalbill146
Junior Member
Thread Starter
 
Member Since: Apr 2018
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default ECM Question

I had my 93 in to the dealer for a cooling fan not comming on until engine temp got over 200, when turning on air the other fan came on and cooled back to normal, dealer said I had a couple grounds not working in ECM module?
Signalbill146 is offline  
Old 04-16-2018, 02:38 PM
  #2  
Kevova
CF Senior Member
 
Kevova's Avatar
 
Member Since: Sep 2013
Location: near the thumb in the mitten
Posts: 3,135
Thanked 300 Times in 284 Posts
Default

Cooling fan comes on at 226* it should turn off at 208*.
Kevova is offline  
Old 04-17-2018, 10:15 AM
  #3  
bac22
CF Senior Member
 
bac22's Avatar
 
Member Since: Feb 2000
Location: Epping NH
Posts: 5,364
Thanked 79 Times in 73 Posts
Default

Always good to post to the forum before wasting time with the dealer...basically you explained normal operation as Kevova point out. And the dealer is clearly handing you a line of BS...basically they're clueless, but to not look clueless, they instead blame grounding points.

Last edited by bac22; 04-17-2018 at 10:16 AM.
bac22 is offline  
Old 04-17-2018, 10:28 AM
  #4  
WVZR-1
CF Senior Member
 
Member Since: Sep 2003
Location: Charles Town WV
Posts: 17,275
Thanked 964 Times in 925 Posts
Default

Originally Posted by bac22 View Post
Always good to post to the forum before wasting time with the dealer...basically you explained normal operation as Kevova point out. And the dealer is clearly handing you a line of BS...basically they're clueless, but to not look clueless, they instead blame grounding points.
That's maybe HARSH!

There's things that the OP mentions that makes the dealers observation maybe correct. OP mentioned that AC turned on 'only' the secondary fan and if ECM operation was correct AC I'm quite sure should have turned on also the primary.

OP doesn't understand the C4 obviously so I'd think for the OP he first needs to 'learn' the gauge function of the DIC and confirmation of TEMPS from the cluster and NOT the analog gauge. We don't know that he isn't aware and maybe that's what he used but depending upon 'whatever' else the dealer did for the diagnostics is important. OP mentioned none of what the entire diagnostics were. Dealer may very well have done complete diagnostics - I would think 'clueless' doesn't necessarily apply.

Does he have an ECM issue? Maybe - it wouldn't be uncommon for '92/'93. Does he need further diagnostics? For sure.

I don't believe the specs mentioned in #2 are correct as I believe '93 has multiple on/off dependent upon which fan. I didn't look but best I recall that's correct.

Last edited by WVZR-1; 04-17-2018 at 10:33 AM.
WVZR-1 is online now  


Thread Tools
Search this Thread
Quick Reply: ECM Question


Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: