Notices
C5 Forced Induction/Nitrous C5 Corvette Turbochargers, Superchargers, Centrifugal, Twin Screw & Roots Blowers, Twin Turbo Kits, Intercoolers, Wet & Dry Nitrous Injection, Meth
Sponsored by:
Sponsored by:

A&A w/ 3.8, Gates K060910 RPM belt LOOSE??

 
Old 05-06-2019, 11:50 AM
  #1  
DrRaySomeDay
CF Senior Member
Thread Starter
 
Member Since: Dec 2015
Location: Owasso Oklahoma
Posts: 256
Received 25 Likes on 19 Posts
Default A&A w/ 3.8, Gates K060910 RPM belt LOOSE??

I installed a new Gates RPM belt on my A&A powered car last night. I got the K060910 size that was recommended. We got it properly tightened last night, it had a bit of squeal at first, but a bit of belt conditioner spray and she was good. This morning, I started the Vette up while I moved another car and thought it sounded a lot quieter than usual. I realized I didn't hear the blower. I popped the hood and realized the belt was not moving. None of the accessories we're going. I saw a little bit of slack in the belt and touched it with a screwdriver to see how much give it had. As soon as I touched it, everything started spinning. The belt looked noticeably 'floppy' though. I stopped the car, ensured the belt was routed correctly and not missing any pulleys and everything was as it should be. The J bracket on the supercharger is as far to the left (toward driver's side) as it can go, it cannot get any tighter. Any ideas?
DrRaySomeDay is offline  

Thread Tools
Search this Thread
Quick Reply: A&A w/ 3.8, Gates K060910 RPM belt LOOSE??


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: