Electrical issue - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C5 Tech Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace
Sponsored by:
Sponsored by:

Electrical issue

Old 10-08-2018, 04:43 PM
  #1  
basslake
Junior Member
Thread Starter
 
Member Since: Oct 2018
Posts: 1
Thanked 0 Times in 0 Posts
Default Electrical issue

I have 2003 Vette- appears it has no electrical problem- hood light not on and tail lights do not light when brake pedal down. One year old battery appears ok - green on trickle charger
basslake is offline  
Old 10-08-2018, 10:59 PM
  #2  
digitaloutsider
CF Member
 
Member Since: Dec 2017
Posts: 72
Thanked 29 Times in 20 Posts
Default

For the hood light, are you sure it's plugged in? Sounds stupid, but that seems to be the case every time.
digitaloutsider is offline  
The Following User Says Thank You to digitaloutsider For This Useful Post:
basslake (10-09-2018)
Old 10-11-2018, 03:02 PM
  #3  
aj98
CF Senior Member
 
aj98's Avatar
 
Member Since: Dec 2005
Location: SE VA VA
Posts: 1,908
Thanked 142 Times in 116 Posts
Default

Agree on the hood light harness..
Local ervice department has forgotten to reconnect it more than once.
If the harness is still connected, check the bulb. Minces blown once or twice

for the tail lights....do the parking lights work?
(and)
check the fuse(s).
aj98 is offline  


Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory

Contact Us Archive Advertising Cookie Policy Privacy Statement Terms of Service

© 2018 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: