Notices
C6 Forced Induction/Nitrous C6 Corvette Turbochargers, Superchargers, Pulley Upgrades, Intercoolers, Wet and Dry Nitrous Injection, Meth
Sponsored by:
Sponsored by:

Boost issues

 
Old 07-02-2019, 01:39 PM
  #1  
SteveSierra
CF Senior Member
Thread Starter
 
Member Since: Jun 2017
Posts: 186
Likes: 0
Received 8 Likes on 8 Posts
Default Boost issues

Hi all just wondering if you can advise me please.
Move been having problems when accelerating in 3rd and 4th where the car would feel like itís bogging down and the shift light on the boost controller will light up when at around 4000rpm (light is set at 6250rpm). 1st and 2nd pulls seem fine.

I then hen switched the boost controller off so itís just on wastegate spring and the car pulls fine in every gear. Wastegate spring is 5psi.

Boost controller is a innovate scg-1 and set on 65% wastegate duty, 0% gain, base spring 3psi.

Any ideas what what this could be? Does this sound like back pressure?
originally I thought my clutch was slipping as the shift light kept flashing but when looking today I noticed rpm were still down.
SteveSierra is offline  
Old 07-04-2019, 03:43 AM
  #2  
SteveSierra
CF Senior Member
Thread Starter
 
Member Since: Jun 2017
Posts: 186
Likes: 0
Received 8 Likes on 8 Posts
Default

Anyone help please?
SteveSierra is offline  
Old 07-04-2019, 11:35 AM
  #3  
Docmartin
Junior Member
 
Docmartin's Avatar
 
Member Since: Apr 2019
Location: Raleigh
Posts: 8
Received 0 Likes on 0 Posts
Default

Damn Steve it really looks like you've hard a tough time with that kit.

Did you ever get things up and running smoothly? If it has been running correctly for a while don't you think you've narrowed it down to a EBC issue? Especially if it runs fine off of the spring alone and the shift lights aren't going off when they are supposed to. Makes me think the EBC isn't acting right, but I don't have enough experience to be truly helpful.

Did you ever reroute the EBC as recommended back in Feb? That EBC isn't terribly expensive on Amazon in the US. Ever thought of swapping in a new one?

Hopefully some of the experienced folks chime in for you.

Both my parents are from the UK and when I visit I'm always thinking about how anyone could drive a Vette on those narrow *** roads with huge speed bumps and speed cameras everywhere. A turbo Vette over there must be a true rare beast. Good luck.
Docmartin is offline  
Old 07-04-2019, 01:34 PM
  #4  
SteveSierra
CF Senior Member
Thread Starter
 
Member Since: Jun 2017
Posts: 186
Likes: 0
Received 8 Likes on 8 Posts
Default

Hi thanks for the reply, itís been a bit of a mess really and I havenít really driven the car much. Was a bit down and fed up after spending so much time and money on it and it not working as it should.
The car has never driven right when going into boost and Iíve only just tried it by turning the EBC off. Like I said on the spring alone it drives ok ish and pulls in all gears, albeit a max of 4.4-5psi. When going beyond that is when the trouble starts.
I suppose Iím guessing and kinda hoping itís a back pressure issue as the downpipe is only 2.5í and the wastegate is routed weirdly. That way I can just get that sorted (over $2k) 😳.
But another part of me wonders how others that have run this turbo and kit have supposedly run 700rwhp and not had these same issues.
SteveSierra is offline  
 


Thread Tools
Search this Thread
Quick Reply: Boost issues


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: