Check Engine Light on - CorvetteForum - Chevrolet Corvette Forum Discussion

Notices
C7 Forced Induction/Nitrous C7 Corvette Turbochargers, Superchargers, Pulley Upgrades, Intercoolers, Wet and Dry Nitrous Injection, Meth
Sponsored by:
Sponsored by:

Check Engine Light on

Reply

 
 
 
Old 06-14-2018, 09:07 AM
  #1  
Ed'sC7
CF Senior Member
Thread Starter
 
Ed'sC7's Avatar
 
Member Since: Mar 2015
Location: LI New York
Posts: 269
Thanked 13 Times in 13 Posts
Default Check Engine Light on

Had a real nice track day on Friday but it all ended with the the check engine light turning on. I have a 2017 GS with an Edlebrock e-force stage 1 kit on it. the only other mods are a Borla x-pile and exhaust. The tune was done by edelbrock by mailing in my ECU to then and then reinstalling it when I put the kit on back in November. All has been working well until this Fridays track day. The check engine code it threw is p0171. System too lean Bank#1. Have any of you with an e-force had this issue. If so, what was the fix? If not, do any of you know where to look first since it can be one of a 1/2 doz reasons.

Thanks -Ed
Ed'sC7 is offline  
Reply With Quote
Old 06-14-2018, 09:55 AM
  #2  
robert miller
CF Senior Member
 
robert miller's Avatar
 
Member Since: Jan 2007
Location: cookeville tennessee
Posts: 25,212
Thanked 915 Times in 829 Posts
Default ttt

I would pull your 02 from the drivers side & look at it. Per say they tune there stuff to run rich on the car just due to running them on the track. But 02 sensor may be going. Are you could reset the code & try it again. But for sure I would give them a call & get what they tell you to look at... Robert
robert miller is online now  
Reply With Quote
The Following User Says Thank You to robert miller For This Useful Post:
Ed'sC7 (06-14-2018)
Old 06-14-2018, 10:47 AM
  #3  
Ed'sC7
CF Senior Member
Thread Starter
 
Ed'sC7's Avatar
 
Member Since: Mar 2015
Location: LI New York
Posts: 269
Thanked 13 Times in 13 Posts
Default

Originally Posted by robert miller View Post
I would pull your 02 from the drivers side & look at it. Per say they tune there stuff to run rich on the car just due to running them on the track. But 02 sensor may be going. Are you could reset the code & try it again. But for sure I would give them a call & get what they tell you to look at... Robert
I'll do that - Thanks
Ed'sC7 is offline  
Reply With Quote
Reply
 
 
 

Forum Jump

Thread Tools
Search this Thread
Sponsored Ads
Vendor Directory
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: