Notices
Audio/Electronics Stereo System Installation Info, Amplifiers, Subwoofers, Radar Detectors, Police Scanners, and CB Radios for the Corvette

New head unit not sitting flush...

 
Old 07-01-2019, 10:08 AM
  #1  
RyaneC
CF Member
Thread Starter
 
Member Since: May 2016
Location: Chester SC
Posts: 89
Received 6 Likes on 5 Posts
Default New head unit not sitting flush...

Hey guys. We recently put in a new Kenwood DNX695S in my 2005. Ordered the proper dash install kit as recommended by Crutchfield and all recommended accessories as well. Head unit is working great, but there is about a 1/4-1/3" gap between the edges of the install kit and the actual face of the head unit itself. Should it be this way? It looks a bit tacky and unpolished, especially sitting in a Corvette. We couldn't get the head unit to slide into the dash kit from the front as most do, and the whole dash kit install was just a bit weird. A coworker helped me with everything - he used to do installs for a living years ago - and said he'd never seen one quite like that. Do you think we should order a new dash kit and start over, that maybe it's a bad casting or something?

I can go out and snap a few pictures if that would help.

Thanks!

Last edited by RyaneC; 07-01-2019 at 10:09 AM.
RyaneC is offline  
Old 07-01-2019, 10:46 AM
  #2  
Coyote58
Junior Member
 
Coyote58's Avatar
 
Member Since: Dec 2018
Location: Arizona
Posts: 25
Received 2 Likes on 2 Posts
Default

Lets see a picture. I used a Metra kit in mine. Its only about $12. it worked nicely. I have had to (on other installs) add foam tape around the back of the unit to help hide gabs around the radio. But, my kit fit a Pioneer radio very well.
Coyote58 is offline  
Old 07-01-2019, 11:34 AM
  #3  
RyaneC
CF Member
Thread Starter
 
Member Since: May 2016
Location: Chester SC
Posts: 89
Received 6 Likes on 5 Posts
Default

Its dirty and the pictures are crap but they were on the fly so it is what it is. They aren't great but they give you an idea.





RyaneC is offline  
Old 07-01-2019, 04:11 PM
  #4  
VinceC5
CF Senior Member
 
VinceC5's Avatar
 
Member Since: Sep 2004
Location: Spring Texas
Posts: 1,146
Received 17 Likes on 17 Posts
Default

The side brackets that mount to the radio were not installed properly. Looks like the bracket is flush with the radio, but it should be on line with the aluminum radio case.
VinceC5 is online now  
 


Thread Tools
Search this Thread
Quick Reply: New head unit not sitting flush...


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: