C4 Tech/Performance L98 Corvette and LT1 Corvette Technical Info, Internal Engine, External Engine

Cooling fan always running ?

 
Old 11-25-2001, 01:04 AM
  #1  
RED84CF
CF Senior Member
Thread Starter
 
RED84CF's Avatar
 
Member Since: Mar 2000
Location: Glenshaw, Pa. Near Pittsburgh U.S.A.
Posts: 1,204
Liked 18 Times in 16 Posts
Default Cooling fan always running ?

This is on an 84. Came back from the repair shop today. Thinks done where: Fix leaking tranny pan gasket & leaking O ring where shift selector enters tranny. Also new tranny filter & service. Replace air pump (bad bearings). Replace water pump (bad bearings). Since I got it back the cooling fan runs all the time. Before it went to the shop the fan only ran when temp got to over 200 and shut off at 185. The 84 cooling fan runs off the fan switch located in the cylinder block and when the air conditioner is on. Any ideas why it is running all the time now. The repair shop is owned by my best friend so I know they will take care of the problem but they are not Corvette techs. I hate when this happens either they did something wrong, pinch wires, hook up something wrong, or maybe the fan relay just went bad? :confused:
RED84CF is offline  
Old 11-25-2001, 10:30 AM
  #2  
HWoods
CF Senior Member
 
Member Since: Aug 2000
Location: Houston, TX
Posts: 1,314
Likes: 0
Liked 0 Times in 0 Posts
Default Re: Cooling fan always running ? (RED84CF)

Red84, the fan switch in the head may be bad, the fan relay may have gone bad, or the shop may have shorted out a wire when they were servicing your car. Do you have a shop manual to trouble shoot the fan relay?
HWoods is offline  
Old 11-25-2001, 08:02 PM
  #3  
RED84CF
CF Senior Member
Thread Starter
 
RED84CF's Avatar
 
Member Since: Mar 2000
Location: Glenshaw, Pa. Near Pittsburgh U.S.A.
Posts: 1,204
Liked 18 Times in 16 Posts
Default Re: Cooling fan always running ? (HWoods)

Thanks for your reply HWoods. I got a chance to trouble shoot it today. I found that the wires from the fan switch in cylinder and the air conditioner that both go to the fan relay when grounded activate the relay and turn the fan on. The deal is when the air conditioner is turned on the fan runs all the time. When the air conditioner is turned off the fan operates from the fan switch in the cylinder block on at 200 off at 185. The wire to the air conditioner has a connector on the end which plugs into a single pin on the air conditioner. I found this pin to be bent and crimped but most of all it is loose and moves all around. I think it should be tight where it comes out of the air conditioner body. Maybe it is grounding out because it is loose. If it is grounding out all of the time than the fan would run all the time. I unconnected this wire and the fan now runs off the fan switch in block the way it should with air off. I will show this to the shop guys when I take it back. It looks like the shop did this when they where replacing the water pump. The air conditioner compresser was put on new last year and every thing had worked fine since.
RED84CF is offline  

Thread Tools
Search this Thread
Quick Reply: Cooling fan always running ?


Sponsored Ads
Vendor Directory

Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: