Notices
C6 Tech/Performance LS2, LS3, LS7, LS9 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace
Sponsored by:
Sponsored by:

2012 no start no power nothing works

 
Old 06-01-2019, 05:19 PM
  #1  
Andyv316
Junior Member
Thread Starter
 
Member Since: Nov 2015
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default 2012 no start no power nothing works

Hey all, so hear me out.i bought a wrecked 2012 z06. Has a brand new ls7 in it. It started and drove to my house as well as when I went and looked at it. I started working on it and must have left something on draining the battery. I said oh well I'll take it out and charge it. 2 days later it was fully charged and tested good at advance. So took it and dropped it back in. The only thing that turns on is the courtesy lights. No lights in the dash, cant go to accessory mode, just a click in the fuse block if the button is pushed. So I purchased a new battery. Installed, still nothing. The doors wont even open electronically. The little red light on top of the panel turns on but nothing else.

Replaced on car because of damage;
Passenger door(changed the harness and all electronics with original), fender, rear quarter
Roof panel
It needs a windshield

Also checked starter and all fuses. Unconnected bcm and reseated it.

All I get is this. When I try to open the doors, the little red light on the lock lites up. All interior lights work, come on then turn off, then will cycle again. Radio makes a noise like it's trying to read a CD. And the push button start will light up green. But it will not crank, wont go to accessory. No dash lights. Headlights will turn on, hazards work.

with probing the fuses today, I discovered that the ECM fuse that is in the bcm does not get power and neither does the run crank fuse.

again there is no lights on the dash, no security lights, I've put a new battery in the fob and have tried to put the fob in the slot.

I'm at witts end. Looking for possible next step

Andyv316 is offline  
Old 06-01-2019, 10:15 PM
  #2  
freaknbigpanda
CF Senior Member
 
Member Since: Mar 2014
Posts: 385
Likes: 0
Received 2 Likes on 2 Posts
Default

I don't have any advice but this sounds similar to the problems that I am having with my 2009 z06, you mentioned that it had a bran new ls7 in it. Did the previous LS7 blow up? Hopefully we can both of our cars back on the road. See my thread here:

https://www.corvetteforum.com/forums...eo-inside.html
freaknbigpanda is offline  
Old 06-01-2019, 10:18 PM
  #3  
Andyv316
Junior Member
Thread Starter
 
Member Since: Nov 2015
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

The previous ls7 had valve train noise. Replaced under GM warranty. Then the car got wrecked.
Andyv316 is offline  
Old 06-11-2019, 07:39 PM
  #4  
Andyv316
Junior Member
Thread Starter
 
Member Since: Nov 2015
Posts: 6
Likes: 0
Received 0 Likes on 0 Posts
Default

So the car is at the shop. They are saying my keyless entry module is dead. They also say my bcm is turning on. My question is which feeds which. Bcm tell the module to turn on or the module tell the bcm to turn on?
Andyv316 is offline  
 


Thread Tools
Search this Thread
Quick Reply: 2012 no start no power nothing works


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: