Notices
C6 Tech/Performance LS2, LS3, LS7, LS9 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace
Sponsored by:
Sponsored by:

Ambient Temp Sensor Issue

 
Old 06-06-2019, 12:16 PM
  #1  
LJD51
CF Senior Member
Support Corvetteforum!
Thread Starter
 
LJD51's Avatar
 
Member Since: Aug 2005
Location: Eastern NC; US Army Retired x 2 (70-90 AD) (91-16 DAC); yea, I'm old.
Posts: 4,266
Received 54 Likes on 36 Posts
Default Ambient Temp Sensor Issue

I am having an intermittent issue with the outside temp sensor; it will be 85 degrees outside and the inside reading will read totally different. Sometimes it will change to the actual outside temp within a few minutes; other times it will take a couple of hours.

If I want to install a new one, is it easily accessible so I can do it and does it require any type of BCM flash to be recognized?

LJD51 is offline  
Old 06-06-2019, 02:12 PM
  #2  
Sayfoo
CF Senior Member
 
Sayfoo's Avatar
 
Member Since: Sep 2005
Location: Orange County Ca
Posts: 1,614
Received 41 Likes on 36 Posts
Default

Before replacing it, you might try disconnecting the battery for a bit and see if it resets. Seems to work with a variety of electrical issues.
Sayfoo is offline  
The following users liked this post:
LJD51 (06-06-2019)
Old 06-07-2019, 02:23 PM
  #3  
irok
CF Senior Member
 
Member Since: May 2011
Location: Oshawa, Ontario
Posts: 2,963
Received 248 Likes on 230 Posts
Default

press front, rear defrost button along with fan speed up or down button all at the same time and temperature will update instantly.The sensor is on the lower passenger side of rad and not to difficult to change.Cost is about $15. for a new one.No need to reflash anything if you replace it

Last edited by irok; 06-07-2019 at 02:24 PM.
irok is offline  
The following 2 users liked this post by irok:
LJD51 (06-08-2019), mikeCsix (06-11-2019)
Old 06-11-2019, 10:00 AM
  #4  
dr_gallup
CF Senior Member
 
dr_gallup's Avatar
 
Member Since: Feb 2016
Location: SC
Posts: 1,711
Received 180 Likes on 153 Posts
Default

There is supposed to be logic to the updating of the outside temperature display but I agree, sometimes it's very slow to do it. They try to avoid a false high reading caused by heat soak from the engine. So at start up with the engine off for less than 3 hours it will display the last stored temp rather than the actual measured temp if the measured temp is higher. Then after the vehicle starts moving for 5 minutes it will slowly update the temp at a filtered rate.
dr_gallup is offline  

Thread Tools
Search this Thread
Quick Reply: Ambient Temp Sensor Issue


Contact Us - About Us - Archive - Advertising - Cookie Policy - Privacy Statement - Terms of Service

© 2019 MH Sub I, LLC dba Internet Brands

We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
 
  • Ask a Question
    Get answers from community experts
Question Title:
Description:
Your question will be posted in: