Reverse lights dont work? - CorvetteForum - Chevrolet Corvette Forum Discussion


C5 Tech
Corvette Tech/Performance: LS1 Corvette Technical Info, Internal Engine, External Engine, Tech Topics, Basic Tech, Maintenance, How to Remove & Replace
Sponsored by:
Sponsored by:

Reverse lights dont work?

Closed Thread
 
 
 
Thread Tools Search this Thread
Old 02-20-2010, 09:22 PM   #1
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default Reverse lights dont work?

I noticed my reverse lights don't work when my car is in reverse...however they do flash when i lock the car with the key fob.. Is there a fuse for the reverse sensor? Is the sensor on the shifter or in the transmission? Not sure where to start. Thanks
DomZ06 is offline  
Old 02-20-2010, 09:31 PM   #2
65GGvert
CF Senior Member
 
65GGvert's Avatar
 
Member Since: Jul 2006
Location: Kannapolis NC
Posts: 13,524
Thanked 590 Times in 538 Posts
Default

You can do better than that. Is it auto or manual? You don't have your profile filled out and you don't give the info in the question. They are not the same. I have a picture and instructions to change the backup light switch in the transmission if it's a manual. Let me know.
65GGvert is offline  
Old 02-20-2010, 09:51 PM   #3
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by 65GGvert View Post
You can do better than that. Is it auto or manual? You don't have your profile filled out and you don't give the info in the question. They are not the same. I have a picture and instructions to change the backup light switch in the transmission if it's a manual. Let me know.
Sorry, im a new Vette owner and new to the forum. Its a 2003 Z06, so it is a manual.
DomZ06 is offline  
Old 02-20-2010, 10:13 PM   #4
65GGvert
CF Senior Member
 
65GGvert's Avatar
 
Member Since: Jul 2006
Location: Kannapolis NC
Posts: 13,524
Thanked 590 Times in 538 Posts
Default



It's on the transmission, passenger side. Unplug the wire and short the two pins in the plug you pull off together with a jumper or needle nose pliers. Turn on the key, if the b/u lights come on, the switch is bad (common). The switch unscrews out of the transmission, screw in a new one, reconnect the plug and you're done. You don't have to drain anything. It's harder to jack up the car than to change the switch. If you have a connection to someone with a lift, you're in business.
65GGvert is offline  
Old 02-20-2010, 10:18 PM   #5
csc67
CF Senior Member
 
Member Since: Apr 2001
Location: Rochester, NY
Posts: 532
Thanks: 0
Thanked 2 Times in 2 Posts
Default

When my reverse lights didn't work, I replaced the reverse light switch on my tranny - If I remember correctly, it was only about $20.00
csc67 is offline  
Old 02-20-2010, 10:26 PM   #6
clayton1
CF Senior Member
 
clayton1's Avatar
 
Member Since: May 2006
Location: Fort St John B.C
Posts: 4,287
Thanks: 0
Thanked 2 Times in 2 Posts
Default

When my reverse light didnt work but they worked with fob lock it was the fuse, not the switch.
clayton1 is offline  
Old 02-21-2010, 05:57 PM   #7
65GGvert
CF Senior Member
 
65GGvert's Avatar
 
Member Since: Jul 2006
Location: Kannapolis NC
Posts: 13,524
Thanked 590 Times in 538 Posts
Default

Still not checked it?
65GGvert is offline  
Old 02-21-2010, 06:31 PM   #8
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I went out today and there is no fuse i was able to find only a relay. I dont have access to a lift and and theres snow on my driveway so i went ahead and ordered the switch for 9.99 at autozone.. Hopefully that does the trick. Thanks for that diagram as well!
DomZ06 is offline  
Old 02-21-2010, 06:35 PM   #9
ronssito
CF Senior Member
 
ronssito's Avatar
 
Member Since: Jul 1999
Location: Silicon Valley
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by DomZ06 View Post
I noticed my reverse lights don't work when my car is in reverse...however they do flash when i lock the car with the key fob.. Is there a fuse for the reverse sensor? Is the sensor on the shifter or in the transmission? Not sure where to start. Thanks

Same here! I'll be replacing the Tranny switch next week.






ronssito is offline  
Old 02-21-2010, 09:01 PM   #10
ronssito
CF Senior Member
 
ronssito's Avatar
 
Member Since: Jul 1999
Location: Silicon Valley
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Just got my switch at Kragens <$10 ... will install next week.





ronssito is offline  
Old 02-21-2010, 09:27 PM   #11
0TheRadioFlyer97
CF Senior Member
St. Jude Donor '08
 
TheRadioFlyer97's Avatar
 
Member Since: Nov 2005
Location: Spring Texas
Posts: 8,995
Thanks: 0
Thanked 1 Time in 1 Post
Default

Before you do any of that, check your fuse. The fob flashing fuse is on a seperate circuit from the actual reverse light fuse.
TheRadioFlyer97 is offline  
Old 02-22-2010, 03:33 AM   #12
DomZ06
Junior Member
Thread Starter
 
Member Since: Jan 2010
Posts: 49
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TheRadioFlyer View Post
Before you do any of that, check your fuse. The fob flashing fuse is on a seperate circuit from the actual reverse light fuse.
I couldnt find any fuses for it, only the relays and the one for the rev lights was diff then the rest so i couldnt switch 2 to check it...
DomZ06 is offline  
Old 02-22-2010, 07:40 AM   #13
Len90Vette
CF Senior Member
St. Jude Donor '10
 
Len90Vette's Avatar
 
Member Since: Jun 2004
Location: Duncan South Carolina
Posts: 534
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had the same problem. Checked the fuse and it was blown. Replaced fuse and put car in reverse and fuse blew again. Replaced switch and lights have worked fine since.

Many thanks to the CF guys for their tutorials.
Len90Vette is offline  
Old 02-22-2010, 11:41 AM   #14
baddboyz03
CF Senior Member
 
baddboyz03's Avatar
 
Member Since: Sep 2007
Location: woodbridge,VA Myrtle Beach,SC
Posts: 690
Thanks: 0
Thanked 3 Times in 3 Posts
Default

the fuse box w/reverse lights in it is under the dash,passenger side,floor board, pull the carpet down look way up under dash, its there!
baddboyz03 is offline  
Old 02-22-2010, 12:26 PM   #15
ronssito
CF Senior Member
 
ronssito's Avatar
 
Member Since: Jul 1999
Location: Silicon Valley
Posts: 2,766
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by TheRadioFlyer View Post
Before you do any of that, check your fuse. The fob flashing fuse is on a seperate circuit from the actual reverse light fuse.
Did that weeks ago ... fuse is OK.

Thanks.

ronssito is offline  
Old 02-24-2010, 03:48 AM   #16
DarkSpeed
CF Senior Member
 
DarkSpeed's Avatar
 
Member Since: Jan 2010
Location: Glendale CA
Posts: 586
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hey guys, I just noticed that once I switched to LED reverse lights, they turn on very dim when key is in 2nd position (right before ignition), never did this before as far as I remember with normal lights...when car goes into reverse, works fine at full brightness, but they seem to be on dimly all the time...

Have any of you encountered this?
DarkSpeed is offline  
Old 02-24-2010, 09:41 AM   #17
65GGvert
CF Senior Member
 
65GGvert's Avatar
 
Member Since: Jul 2006
Location: Kannapolis NC
Posts: 13,524
Thanked 590 Times in 538 Posts
Default

I've never heard that, but from a strictly electrical standpoint, if they are only on dimly with the key on there must be a high resistance short in the b/u light switch. It supplies voltage to the lamps and they are grounded on the other side, so if they are glowing the voltage could be "leaking" through the switch. It may not be opening the contact fully when not in reverse. You can buy a b/u switch for around 10 bucks and disconnect the plug on the transmission and plug it into the new switch to see if the lamps still glow. Check for any conductive material in the plug that would cause the voltage to bypass the switch while your down there. Post what you find.
65GGvert is offline  
Old 02-24-2010, 12:20 PM   #18
BELVIN20
CF Senior Member
 
BELVIN20's Avatar
 
Member Since: Oct 2005
Location: Terrell North Carolina
Posts: 534
Thanked 99 Times in 71 Posts
Default

Check fuse #20, it will be marked as a park, neutral fuse, but you do not have that fuse since it is a MN6. I if the fuse blows after you replace it, the the reverse switch in the trans is bad.
BELVIN20 is offline  
Old 02-24-2010, 01:40 PM   #19
DarkSpeed
CF Senior Member
 
DarkSpeed's Avatar
 
Member Since: Jan 2010
Location: Glendale CA
Posts: 586
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by BELVIN20 View Post
Check fuse #20, it will be marked as a park, neutral fuse, but you do not have that fuse since it is a MN6. I if the fuse blows after you replace it, the the reverse switch in the trans is bad.
hmmm...if there was a problem with the fuse, the lights wouldnt turn on at all...mine turns on dimly when car is started or in 2nd key position

I'm thinking maybe the relay could be the problem? somehow transferring a low current to dimly light up the LED's?

DarkSpeed is offline  
Old 02-24-2010, 02:24 PM   #20
clayton1
CF Senior Member
 
clayton1's Avatar
 
Member Since: May 2006
Location: Fort St John B.C
Posts: 4,287
Thanks: 0
Thanked 2 Times in 2 Posts
Default

A couple years ago I had the same problem as you DomZ06, and 65GGVert was a great help!!

I just did a search for my old thread and after much messing around you want to check this: For the fuse box under pass kick panel, my book says fuse #21 is "Brake-Transmission Shift Interlock". This is the fuse for the reverse lights. Check it.
clayton1 is offline  
Go Back   CorvetteForum - Chevrolet Corvette Forum Discussion >
Reload this Page
  • Reverse lights dont work?
  •  
     
    Closed Thread

    Related Topics
    Thread Thread Starter Forum Replies Last Post
    Reverse light switch (sensor) Tehtsuo C6 Corvette General Discussion 10 09-17-2017 02:27 PM
    Inside the car reverse light signal? crowz C4 General Discussion 19 05-23-2017 10:40 AM
    Reverse Lights Hawgdified C3 Tech/Performance 15 07-09-2016 11:11 AM
    Tremec TKO reverse light switch irwiny C1 & C2 Corvettes 1 03-29-2016 02:42 AM
    Reverse lights led???????????? c5BigDreamz C5 General 11 03-12-2016 10:28 PM


    Tags
    01, alarm, brakes, c5, change, changed, corvette, dont, flashing, light, lights, reverse, transmission, turn, work

    Thread Tools Search this Thread
    Search this Thread:

    Click for Advanced Search

    Posting Rules
    You may not post new threads
    You may not post replies
    You may not post attachments
    You may not edit your posts

    BB code is On
    Smilies are On
    [IMG] code is On
    HTML code is Off
    Trackbacks are Off
    Pingbacks are Off
    Refbacks are Off

    Forum Jump

    Sponsored Ads
    Vendor Directory

    All times are GMT -4. The time now is 08:38 PM.


    We are a participant in the Amazon Services LLC Associates Program, an affiliate advertising program designed to provide a means for us to earn fees by linking to Amazon.com and affiliated sites.
     
    • Ask a Question
      Get answers from community experts
    Question Title:
    Description:
    Your question will be posted in: